ui_msg " *** To complete the Xymon install *** 1) Tune the number of shared message queues ---------------------------------------------- Xymon server needs at least 9 IPC message queues to run. Unfortunately Mac OS X ships with a default max of 8. Check how much shared segments a process can use on your system: $ sysctl kern.sysv.shmseg And the max number of shared segments system-wide: $ sysctl kern.sysv.shmmni If the first number is < 9, you need to tune your system before trying to start xymon server (doing so will make the whole system to crash). Run the following commands to increase your shared segments: $ sudo echo \"kern.sysv.shmmni=64\" >> /etc/sysctl.conf $ sudo echo \"kern.sysv.shmseg=12\" >> /etc/sysctl.conf Reboot your system to activate the change. After reboot you can read these instructions with: $ cat /opt/local/lib/xymon/INSTALL.macports.xymon.server More information about shared memory segments on Mac OS X can be found here: http://support.apple.com/kb/HT4022 2) Configure your apache web server ---------------------------------------------- Xymon \"make install\" ends with: You must configure your webserver for the Hobbit webpages and CGI-scripts. A sample Apache configuration is in /opt/local/lib/xymon/server/etc/hobbit-apache.conf If you have your Administration CGI scripts in a separate directory, then you must also setup the password-file with the htpasswd command. So the following commands should do it: $ sudo mv /opt/local/lib/xymon/server/etc/hobbit-apache.conf /etc/apache2/sites/ $ sudo /usr/sbin/apachectl restart 3) Make user _xymon part of the admin group: ---------------------------------------------- We achieve this with the Directory Service command line utility: $ sudo dscl . -append /Groups/admin GroupMembership _xymon 4) Start Xymon server ---------------------------------------------- A startup item has been generated that will aid in starting xymon with launchd. It is disabled by default. Execute the following command to start it, and to cause it to launch at startup: $ sudo launchctl load -w /Library/LaunchDaemons/org.macports.xymon.plist If your Mac OSX firewall is enabled, you'll be asked to allow xymon -> accept On Mac OSX Server, make sure your ipfw rules will allow incoming TCP conections to port 1984 5) check the status of your Xymon server ---------------------------------------------- To view the Xymon webpages, go to http://localhost/xymon ---------------------------------------------- *** Quick start for the impatient *** Run the following commands in your terminal: $ sudo echo \"kern.sysv.shmmni=64\" >> /etc/sysctl.conf $ sudo echo \"kern.sysv.shmseg=12\" >> /etc/sysctl.conf $ sudo mv /opt/local/lib/xymon/server/etc/hobbit-apache.conf /etc/apache2/sites/ $ sudo /usr/sbin/apachectl restart $ sudo dscl . -append /Groups/admin GroupMembership _xymon Reboot your system $ sudo launchctl load -w /Library/LaunchDaemons/org.macports.xymon.plist Open http://localhost/xymon in your server's browser "