New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #11621 (closed defect: fixed)

Opened 8 years ago

Last modified 6 years ago

evince fails to build (blocking gnome-desktop-suite)

Reported by: tw.lbean@… Owned by: rhwood@…
Priority: High Milestone:
Component: ports Version:
Keywords: Cc:
Port:

Description

The only other reference I could find on this issue was at: https://launchpad.net/ubuntu/+source/evince-gtk/+bug/89825

It's not clear to me what the issue is, but here's the output of the build:

--- Making all in help xsltproc -o evince-fi.omf --stringparam db2omf.basename evince --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-OASISDTD DocBook XML V4.1.2EN" --stringparam db2omf.lang fi --stringparam db2omf.omf_dir "/opt/local/share/omf" --stringparam db2omf.help_dir "/opt/local/share/gnome/help" --stringparam db2omf.omf_in "pwd/./evince.omf.in" /opt/local/bin/pkg-config --variable db2omf gnome-doc-utils fi/evince.xml db2omf: Could not construct the OMF maintainer element.

Add an author, corpauthor, editor, othercredit, or publisher element with the role attribute set to "maintainer" to evince.xml.

make[2]: * [evince-fi.omf] Error 10 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Error: Status 1 encountered during processing. ---

Attachments

diff (444 bytes) - added by tw.lbean@… 8 years ago.
Patch to evince-0.6.1/C/evince.xml to enable building

Change History

comment:1 Changed 8 years ago by tw.lbean@…

This problem is due to a missing "maintainer" attribute on line 63 of the file "evince-0.6.1/help/C/evince.xml". Other localized files have this attribute attached to the author element on line 63 (e.g. .../help/es/evince.xml).

This appears to be an upstream bug.

Changed 8 years ago by tw.lbean@…

Patch to evince-0.6.1/C/evince.xml to enable building

comment:2 Changed 8 years ago by rhwood@…

  • Owner changed from macports-dev@… to rhwood@…
  • Status changed from new to assigned
  • Version 1.4 deleted
  • severity changed from Serious to Normal

I have upgraded evince to 0.8.0 in changeset:23139 (without applying your patch, since I was unable to recreate your error)

Please let me know if this upgrade does or does not address the issue. If not, then I'll try the patch and report it to the upstream maintainers.

comment:3 Changed 8 years ago by tw.lbean@…

Builds successfully with the new version

comment:4 Changed 8 years ago by rhwood@…

  • Status changed from assigned to closed
  • Resolution set to fixed

Seems to work.

comment:5 Changed 6 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.