New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #13776 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

py25-scipy-0.6.0_2 build failure

Reported by: harrylparker@… Owned by: ram@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: python fortran scipy Cc: harrylparker@…
Port:

Description

I have been having trouble for several weeks upgrading port py25-scipy.

Today I did a port selfupdate and successfully upgraded g95 and tried to upgrade py25-scipy from from version 0.6.0_0. The attempted upgrade ends with:

building 'scipy.interpolate.dfitpack' extension
error: extension 'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler found

Warning: the following items did not execute (for py25-scipy): org.macports.destroot org.macports.build
Error: Unable to upgrade port: 1

I tried this with the default variant and with the +g95 variant set explicitly.

This is on a PowerPC G4 recently upgraded to Mac OS X 10.4.11.

Attachments

scipy0.6.0_2UpgradeOutput.txt (255.2 KB) - added by harrylparker@… 7 years ago.
portsInstalled.txt (3.1 KB) - added by harrylparker@… 7 years ago.
py25-scipyInstallDebugOutput.txt (10.7 KB) - added by harrylparker@… 7 years ago.
The redirected output of "sudo port -d install py25-scipy > py25-scipyInstallDebugOutput.txt".
fullCleanScipyInstallLog.txt (232.7 KB) - added by harrylparker@… 7 years ago.

Change History

comment:1 Changed 7 years ago by ram@…

  • Cc harrylparker@… added; harrylparker@… removed
  • Status changed from new to assigned
  • Owner changed from macports-tickets@… to ram@…

strange as it looks like it can't find a fortran compiler, can you attach the full output of

$ sudo port -d install py25-scipy

to the ticket? along with

$ port installed

Changed 7 years ago by harrylparker@…

Changed 7 years ago by harrylparker@…

comment:2 Changed 7 years ago by ram@…

I can't understand this, as from the build log it successfully compiles fortran code earlier in the build process but can't find the fortran compiler later on... I use the gcc42 variant, as I haven't been able to get g95 to build on Intel Leopard, so I'm unable to duplicate this.

Can you attach the build log again, this time using the -d option instead of the -v option to port as that should tell me in which phase the error is occurring in, i.e. build or destroot

comment:3 Changed 7 years ago by harrylparker@…

I performed the following command as ram requested. The complete screen output is shown. The redirected output file will be attached to this ticket.

Harrys-Silver-PowerBook:~ hparker$ sudo port -d install py25-scipy > py25-scipyInstallDebugOutput.txt
Password:
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py25-scipy
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py25-scipy
DEBUG: Requested variant powerpc is not provided by port py25-scipy.
DEBUG: Requested variant darwin is not provided by port py25-scipy.
DEBUG: Requested variant macosx is not provided by port py25-scipy.
DEBUG: Executing variant g95 provides g95
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/python25
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/python25
DEBUG: Requested variant powerpc is not provided by port python25.
DEBUG: Requested variant darwin is not provided by port python25.
DEBUG: Requested variant macosx is not provided by port python25.
DEBUG: Executing variant darwin_8 provides darwin_8
DEBUG: Searching for dependency: python25
DEBUG: Found Dependency: receipt exists for python25
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/math/gnuplot
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/math/gnuplot
DEBUG: Requested variant powerpc is not provided by port gnuplot.
DEBUG: Requested variant macosx is not provided by port gnuplot.
DEBUG: Executing variant darwin provides darwin
DEBUG: Searching for dependency: gnuplot
DEBUG: Found Dependency: receipt exists for gnuplot
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py25-numpy
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py25-numpy
DEBUG: Requested variant powerpc is not provided by port py25-numpy.
DEBUG: Requested variant darwin is not provided by port py25-numpy.
DEBUG: Requested variant macosx is not provided by port py25-numpy.
DEBUG: Executing variant g95 provides g95
DEBUG: Searching for dependency: py25-numpy
DEBUG: Found Dependency: receipt exists for py25-numpy
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/g95
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/g95
DEBUG: Requested variant powerpc is not provided by port g95.
DEBUG: Requested variant darwin is not provided by port g95.
DEBUG: Requested variant macosx is not provided by port g95.
DEBUG: Searching for dependency: g95
DEBUG: Found Dependency: receipt exists for g95
DEBUG: Skipping completed org.macports.main (py25-scipy)
DEBUG: Skipping completed org.macports.fetch (py25-scipy)
DEBUG: Skipping completed org.macports.checksum (py25-scipy)
DEBUG: Skipping completed org.macports.extract (py25-scipy)
DEBUG: Skipping completed org.macports.patch (py25-scipy)
DEBUG: Skipping completed org.macports.configure (py25-scipy)
DEBUG: Executing org.macports.build (py25-scipy)
DEBUG: Environment: CCFLAGS='-I/opt/local/include -L/opt/local/lib'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-scipy/work/scipy-0.6.0" && /opt/local/bin/python2.5 setup.py config_fc --fcompiler gnu95 --f77exec /opt/local/bin/g95 --f90exec /opt/local/bin/g95 build'
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-scipy/work/scipy-0.6.0" && /opt/local/bin/python2.5 setup.py config_fc --fcompiler gnu95 --f77exec /opt/local/bin/g95 --f90exec /opt/local/bin/g95 build " returned error 1
Command output:   adding 'build/src.macosx-10.3-ppc-2.5/scipy/stats/mvn-f2pywrappers.f' to sources.
building extension "scipy.ndimage._nd_image" sources
building data_files sources
running build_py
copying build/src.macosx-10.3-ppc-2.5/scipy/__config__.py -> build/lib.macosx-10.3-ppc-2.5/scipy
running build_clib
customize UnixCCompiler
customize UnixCCompiler using build_clib
customize Gnu95FCompiler
Found executable /opt/local/bin/g95
Could not locate executable gfortran
Could not locate executable f95
customize Gnu95FCompiler using build_clib
running build_ext
customize UnixCCompiler
customize UnixCCompiler using build_ext
library 'mach' defined more than once, overwriting build_info
{'sources': ['scipy/integrate/mach/d1mach.f', 'scipy/integrate/mach/i1mach.f', 'scipy/integrate/mach/r1mach.f', 'scipy/integrate/mach/xerror.f'], 'config_fc': {'noopt': ('scipy/integrate/setup.pyc', 1)}, 'source_languages': ['f77']}... 
with
{'sources': ['scipy/special/mach/d1mach.f', 'scipy/special/mach/i1mach.f', 'scipy/special/mach/r1mach.f', 'scipy/special/mach/xerror.f'], 'config_fc': {'noopt': ('scipy/special/setup.pyc', 1)}, 'source_languages': ['f77']}...
extending extension 'scipy.linsolve._zsuperlu' defined_macros with [('USE_VENDOR_BLAS', 1)]
extending extension 'scipy.linsolve._dsuperlu' defined_macros with [('USE_VENDOR_BLAS', 1)]
extending extension 'scipy.linsolve._csuperlu' defined_macros with [('USE_VENDOR_BLAS', 1)]
extending extension 'scipy.linsolve._ssuperlu' defined_macros with [('USE_VENDOR_BLAS', 1)]
customize UnixCCompiler
customize UnixCCompiler using build_ext
customize Gnu95FCompiler
warning: build_ext: f77_compiler=gnu95 is not available.
building 'scipy.interpolate.dfitpack' extension
error: extension 'scipy.interpolate.dfitpack' has Fortran sources but no Fortran compiler found

Error: Status 1 encountered during processing.

Changed 7 years ago by harrylparker@…

The redirected output of "sudo port -d install py25-scipy > py25-scipyInstallDebugOutput.txt".

comment:4 Changed 7 years ago by ram@…

This is very odd, the error is occurring in the build phase - yet earlier in the build phase the fortran compiler is used to compile fortran source code without issue... I'll try to reproduce the problem.

Changed 7 years ago by harrylparker@…

comment:5 Changed 7 years ago by harrylparker@…

Last night I tried another install of py2-scipy. This time I first deactivated the activated version and cleaned out the the previous build results. Then I saved the stdout and stderr together. This resulted in in a much larger, 238 KB log file, fullCleanScipyInstallLog.txt. (The previous stdout + screen output totalled 20 KB.)

Here is the transcript of what I did:

Harrys-Silver-PowerBook:~ hparker$ sudo port -v uninstall py25-scipy
Password:
--->  The following versions of py25-scipy are currently installed:
--->    py25-scipy @0.5.2_0
--->    py25-scipy @0.6.0_0 (active)
Error: port uninstall failed: Registry error: Please specify the full version as recorded in the port registry.
Harrys-Silver-PowerBook:~ hparker$ sudo port -v deactivate py25-scipy
--->  Deactivating py25-scipy 
Harrys-Silver-PowerBook:~ hparker$ sudo port -v clean py25-scipy
--->  Cleaning py25-scipy
--->  Removing build directory for py25-scipy
Harrys-Silver-PowerBook:~ hparker$ sudo port -d install py25-scipy &> fullCleanScipyInstallLog.txt
^Z
[1]+  Stopped                 sudo port -d install py25-scipy >&fullCleanScipyInstallLog.txt
Harrys-Silver-PowerBook:~ hparker$ bg
[1]+ sudo port -d install py25-scipy >&fullCleanScipyInstallLog.txt &
Harrys-Silver-PowerBook:~ hparker$ tail fullCleanScipyInstallLog.txt

Then I kept an eye on my activity monitor and continued to use tail to see what was happening.

I hope this new log file helps.

comment:6 Changed 7 years ago by ram@…

I've managed to get g95 built and I get the same error when trying to build the default g95 variant... I'm looking into it.

comment:7 Changed 7 years ago by ram@…

Just an update on this, I still can't work out why the build is failing - I've asked the upstream developers but haven't heard anything back from them... In the meantime try using the gcc42 variants of numpy and scipy as they build fine

comment:8 Changed 7 years ago by ram@…

Heard back from the upstream developers, it turns out that g95 is not a supported compiler on the Mac OS X platform as the appropriate linking flags have not been implemented. So until these have been implemented I'm going to remove the g95 variant and make numpy/scipy depend only upon gcc42. Should be committed shortly.

comment:9 Changed 7 years ago by ram@…

  • Status changed from assigned to closed
  • Resolution set to fixed

fixed in r33371

comment:10 Changed 6 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.