New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #14845 (closed defect: duplicate)

Opened 7 years ago

Last modified 5 years ago

sqlite3 fails to build

Reported by: m.giacco@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: sqlite3 Cc:
Port:

Description

--->  Building sqlite3 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_sqlite3/work/sqlite-3.5.7" && gnumake all " returned error 2
Command output: ./sqlite3.c:73730: error: 'TK_GE' undeclared (first use in this function)
./sqlite3.c:73733: error: 'TK_RSHIFT' undeclared (first use in this function)
./sqlite3.c:73736: error: 'TK_GT' undeclared (first use in this function)
./sqlite3.c:73742: error: 'TK_ILLEGAL' undeclared (first use in this function)
./sqlite3.c:73751: error: 'TK_BITOR' undeclared (first use in this function)
./sqlite3.c:73754: error: 'TK_CONCAT' undeclared (first use in this function)
./sqlite3.c:73759: error: 'TK_COMMA' undeclared (first use in this function)
./sqlite3.c:73763: error: 'TK_BITAND' undeclared (first use in this function)
./sqlite3.c:73767: error: 'TK_BITNOT' undeclared (first use in this function)
./sqlite3.c:73784: error: 'TK_STRING' undeclared (first use in this function)
./sqlite3.c:73796: error: 'TK_DOT' undeclared (first use in this function)
./sqlite3.c:73804: error: 'TK_INTEGER' undeclared (first use in this function)
./sqlite3.c:73810: error: 'TK_FLOAT' undeclared (first use in this function)
./sqlite3.c:73830: error: 'TK_ID' undeclared (first use in this function)
./sqlite3.c:73830: warning: assignment makes integer from pointer without a cast
./sqlite3.c:73834: error: 'TK_VARIABLE' undeclared (first use in this function)
./sqlite3.c:73843: error: 'TK_REGISTER' undeclared (first use in this function)
./sqlite3.c:73883: error: 'TK_BLOB' undeclared (first use in this function)
./sqlite3.c: In function 'sqlite3RunParser':
./sqlite3.c:73956: error: 'TK_SPACE' undeclared (first use in this function)
./sqlite3.c:73956: warning: case label value exceeds maximum value for type
./sqlite3.c:73957: error: 'TK_COMMENT' undeclared (first use in this function)
./sqlite3.c:73957: warning: case label value exceeds maximum value for type
./sqlite3.c:73965: error: 'TK_ILLEGAL' undeclared (first use in this function)
./sqlite3.c:73965: warning: case label value exceeds maximum value for type
./sqlite3.c:73974: error: 'TK_SEMI' undeclared (first use in this function)
./sqlite3.c:73974: warning: case label value exceeds maximum value for type
./sqlite3.c:73990: warning: comparison between pointer and integer
./sqlite3.c:73991: warning: passing argument 2 of 'sqlite3Parser' makes integer from pointer without a cast
gnumake: *** [sqlite3.lo] Error 1

this is the error i get...

Change History

comment:1 Changed 7 years ago by jmr@…

  • Owner changed from macports-tickets@… to mww@…
  • Milestone set to Port Bugs

Assigning to maintainer.

comment:2 follow-up: ↓ 3 Changed 7 years ago by ostefano@…

Any workaround available?

sqlite3 is pretty important due to many packages requiring it.

comment:3 in reply to: ↑ 2 Changed 7 years ago by mrowe@…

Replying to ostefano@gmail.com:

Any workaround available?

I got it working by running "port clean sqlite3" then reinstalling.

comment:4 Changed 7 years ago by bill.mill macforge@…

confirm that both the bug exists and that the workaround works. Thanks mrowe.

comment:5 Changed 7 years ago by rpt38@…

Wanted to add - I was getting bitten by http://trac.macports.org/projects/macports/ticket/14523 at the same time as this, multiple cleans didn't work (I think I was doing a "full" clean). Cleaning and then setting NAWK in the makefile worked.

comment:6 follow-up: ↓ 7 Changed 6 years ago by danm@…

I got the same error. I also got around it by running "port clean sqlite3" and then "port install sqlite3" again.

comment:7 in reply to: ↑ 6 Changed 6 years ago by Dan.Kelley@…

Replying to danm@start.no:

I got the same error. I also got around it by running "port clean sqlite3" and then "port install sqlite3" again.

This works for me, also. DK.

comment:8 Changed 6 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #13305.

comment:9 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.