New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #15556 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

cairo 1.6.4 build fails on panther os x 10.3.9

Reported by: north@… Owned by: ryandesign@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: cairo 1.6.4 fail Cc:
Port:

Description (last modified by jmpp@…) (diff)

Quite a few other packages built well, so the environment seems okay. Here's the relevant spew:

/usr/bin/gcc-3.3 -DHAVE_CONFIG_H -I. -I.. -I/opt/local/include -I. -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include -I/opt/local/include/libpng12 -DXTHREADS -I/opt/local/include -I/usr/X11R6/include -I/usr/X11R6/include -I/opt/local/include/pixman-1 -Wall -Wsign-compare -Werror-implicit-function-declaration -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wpacked -Wswitch-enum -Wmissing-format-attribute -Wno-unused-parameter -Wno-long-long -Winline -fno-strict-aliasing -O2 -MT libcairo_la-cairo-quartz-surface.lo -MD -MP -MF .deps/libcairo_la-cairo-quartz-surface.Tpo -c cairo-quartz-surface.c  -fno-common -DPIC -o .libs/libcairo_la-cairo-quartz-surface.o
In file included from cairo-quartz-surface.c:39:
cairo-quartz-private.h:92: error: parse error before "CGDataProviderReleaseDataCallback"
cairo-quartz-private.h:93: warning: function declaration isn't a prototype
cairo-quartz-surface.c: In function `_cairo_quartz_fixup_unbounded_operation':
cairo-quartz-surface.c:508: error: implicit declaration of function `CGContextClipToMask'
cairo-quartz-surface.c: In function `_cairo_surface_to_cgimage':
cairo-quartz-surface.c:749: error: implicit declaration of function `CGImageCreateCopy'
cairo-quartz-surface.c:749: warning: assignment makes pointer from integer without a cast
cairo-quartz-surface.c: In function `_cairo_quartz_setup_fallback_source':
cairo-quartz-surface.c:940: error: implicit declaration of function `CGRectApplyAffineTransform'
cairo-quartz-surface.c:940: error: incompatible types in assignment
cairo-quartz-surface.c: In function `_cairo_quartz_setup_source':
cairo-quartz-surface.c:1168: error: incompatible types in assignment
cairo-quartz-surface.c:1184: error: incompatible types in assignment
make[2]: *** [libcairo_la-cairo-quartz-surface.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Change History

comment:1 Changed 6 years ago by jmr@…

  • Owner changed from macports-tickets@… to ryandesign@…
  • Milestone set to Port Bugs

Assigning to maintainer.

comment:2 Changed 6 years ago by ryandesign@…

  • Status changed from new to assigned

Confirmed. I've asked the cairo mailing list about this.

comment:3 Changed 6 years ago by ryandesign@…

  • Status changed from assigned to closed
  • Resolution set to fixed

In a response to my email on the cairo list, Vladimir Vukicevic says "Pretty much all the Quartz backends require at least a recent 10.4.x. The needed methods to render using Quartz just aren't there" so I disabled the Quartz backends in 10.3.x and earlier in r37536. Now cairo builds on 10.3.9.

comment:4 Changed 6 years ago by north@…

Build works for me now. Thank you very much!

comment:5 Changed 6 years ago by jmpp@…

  • Description modified (diff)

comment:6 Changed 6 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.