New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #16023 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

samba3 3.2.0 dynamic libs not well referenced

Reported by: pierre.augeard@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: jeremyhu@…, rick@…, bugs@…
Port: samba3

Description (last modified by ryandesign@…) (diff)

Hi,

Config: xserve, 10.4

After a fresh install of macports and samba (the only port installed on the server), the dyn lib are not well referenced.

otool -L nmbd:
       ...
       bin/libtalloc.dylib (compatibility version 0.0.0, current version 0.0.0)
       bin/libtdb.dylib (compatibility version 0.0.0, current version 0.0.0)
       ...

all the executable have this problem, I am unable to launch the daemons...
I've seen the BAND-AID, but it doesn't seem to work?

Thanks, Pierre

Attachments

Makefile.in (92.3 KB) - added by pierre.augeard@… 6 years ago.
wrong Makefile

Change History

comment:1 Changed 6 years ago by jmr@…

  • Owner changed from macports-tickets@… to mww@…
  • Milestone set to Port Bugs
  • Summary changed from Samba 3.2.0 dynamic libs not welle referenced to samba3 3.2.0 dynamic libs not well referenced

Assigning to maintainer.

Changed 6 years ago by pierre.augeard@…

wrong Makefile

comment:2 Changed 6 years ago by pierre.augeard@…

I've attached the makefile which seems to be clean. The link variable for LIBTDB_SHARED_TARGET and LIBTALLOC_SHARED_TARGET is SHLD_DSO defined here:

SHLD_DSO = $(SHLD) $(LDSHFLAGS) $(DSO_EXPORTS) -o $@

is not modified with the -install_name param should I fix it like that?

SHLD_DSO = $(SHLD) $(LDSHFLAGS) -install_name @libdir@/`basename $@` $(DSO_EXPORTS) -o @

comment:3 Changed 6 years ago by pierre.augeard@…

My apologies, the Makefile doesn't seem to be clean.

Do we have to do the same for the SHLD_MODULE variable?
I rather sceptic because these specific *.dylib will be located in sub directories of {prefix}/lib/samba3.

comment:4 Changed 6 years ago by pierre.augeard@…

Well I'm sorry for the spam...:

Now the dylib references to libtalloc and libtdb are ok.

But when I launch the smbd daemon, it crashes with the following log:

passdb/pdb_interface.c:make_pdb_method_name(133)
  Attempting to find an passdb backend to match guest (guest)
passdb/pdb_interface.c:make_pdb_method_name(139)
  No builtin backend found, trying to load plugin
lib/module.c:smb_probe_module(111)
  Probing module 'guest'
lib/module.c:smb_probe_module(130)
  Probing module 'guest': Trying to load from /opt/local/lib/samba3/pdb/guest.dylib
lib/module.c:do_smb_load_module(48)
  Error loading module '/opt/local/lib/samba3/pdb/guest.dylib': dlopen(/opt/local/lib/samba3/pdb/guest.dylib, 1)
: image not found
passdb/pdb_interface.c:make_pdb_method_name(149)
  No builtin nor plugin backend for guest found
lib/util.c:smb_panic(1666)
  PANIC (pid 27530): pdb_get_methods_reload: failed to get pdb methods for backend guest

In the makefile I can see:

PDB_MODULES = 
AUTH_MODULES =  bin/script.dylib

So no guest.dylib is created. Is it the normal behavior? What do I have to put in smb.conf to launch correctly the dameon? (sorry this is a very open question)

comment:5 Changed 6 years ago by pierre.augeard@…

Well ok, guest seems to be deprecated... Unfortunately I've also got a critical error with tdbsam, and the log is not too helpful.

[2008/07/22 16:54:25,  0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 10119 (3.2.0)

Actually I really don't see how I can configure samba from macports, it seems that pdb/opendirectorysam vfs/darwin_acls and auth/opendirectory are missing, so I can't copy a osx-compliant smb.conf (3.0.10 shipped with my xserve osx 10.4).

PS: uname -a : 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc

comment:6 Changed 6 years ago by ryandesign@…

  • Description modified (diff)
  • Port set to samba3

comment:7 Changed 6 years ago by blb@…

  • Cc jeremyhu@… added

Cc reporter of dup #17881.

comment:8 Changed 6 years ago by jeremyhu@…

  • Priority changed from Normal to High

comment:9 Changed 6 years ago by jeremyhu@…

r44960 should work around this, but the root cause is not fixed

comment:10 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

comment:11 Changed 5 years ago by toby@…

  • Priority changed from High to Normal

comment:12 Changed 4 years ago by ryandesign@…

  • Cc rick@… added

Has duplicate #28013, suggesting the workaround is not working.

comment:13 Changed 4 years ago by bugs@…

latest Mac OS X, latest ports (as of Feb. 28th 2011), problem still unresolved

workaround:

cd /opt/local/sbin/ mkdir bin cd bin ln -s /opt/local/lib/samba3/libtdb.dylib* . ln -s /opt/local/lib/samba3/libtalloc.dylib* .

to start smbd/nmbd first cd into /opt/local/sbin

cd /opt/local/sbin/ ./smbd -D ./nmbd -D

comment:14 Changed 4 years ago by bugs@…

with better formatting:

cd /opt/local/sbin/ 
mkdir bin 
cd bin 
ln -s /opt/local/lib/samba3/libtdb.dylib* . 
ln -s /opt/local/lib/samba3/libtalloc.dylib* .

to start smbd/nmbd first cd into /opt/local/sbin

cd /opt/local/sbin/ 
./smbd -D 
./nmbd -D

comment:15 Changed 4 years ago by bugs@…

  • Cc bugs@… added

Cc Me!

comment:16 Changed 4 years ago by jeremyhu@…

It looks like the install_name_tool changes left out the sbin binaries.

comment:17 Changed 4 years ago by jeremyhu@…

  • Status changed from new to closed
  • Resolution set to fixed

comment:18 Changed 4 years ago by jeremyhu@…

Closing ... the root cause still isn't fixed, and it's probably not worth fixing with samba4 on the horizon.

Note: See TracTickets for help on using tickets.