New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #17184 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

ghc 6.10.1 upgrade failing on powerpc G4

Reported by: macports@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: ghc segmentation fault Cc:
Port: ghc

Description (last modified by ryandesign@…) (diff)

I am trying to upgrade from ghc 6.8.3 on my laptop (G4 running OS X 10.5.5 and XCode 3.1). The build is failing with a segmentation fault while compiling Apply.o (see attached). I will update this bug if and when I see other behavior.

make[1]: *** [Apply.o] Segmentation fault
make: *** [stage1] Error 2

Error: Unable to upgrade port: 1

Attachments

ghc-build-fail-1 (22.2 KB) - added by macports@… 5 years ago.

Change History

Changed 5 years ago by macports@…

comment:1 Changed 5 years ago by macsforever2000@…

  • Owner changed from macports-tickets@… to gwright@…

Assigning to maintainer.

comment:2 Changed 5 years ago by gwright@…

  • Status changed from new to assigned

I'll try to reproduce this on the ppc machine I have access to, but it runs Tiger.

comment:3 follow-up: ↓ 8 Changed 5 years ago by macports@…

I also posted this error to glasgow-haskell-users@… and they pointed out a suspiciously similar error in their error tracking system:

http://hackage.haskell.org/trac/ghc/ticket/2380

So I think the answer may be to use 6.8.3 instead of 6.8.2 as the bootstrap compiler. Note that I already have the macports ghc-6.8.3 installed. Is it possible for the 6.10.1 installer to detect this and use it instead of its own 6.8.2 binary?

As for working binaries, the ghc-6.10.1 from

http://www.dfki.de/sks/hets/mac/ghcs which redirects to

http://www.informatik.uni-bremen.de/agbkb/forschung/formal_methods/CoFI/hets/mac/ghcs/

is what I am now using until the macports will install. There is also an intel version of the above at

http://www.dfki.de/sks/hets/intel-mac/ghcs which redirects to

http://www.informatik.uni-bremen.de/agbkb/forschung/formal_methods/CoFI/hets/intel-mac/ghcs/

comment:4 follow-up: ↓ 5 Changed 5 years ago by gwright@…

It's not really feasible to build the new ghc with an already installed ghc, as suggested by macports@mightyreason. The main difficulty is that it doubles the number of cases that have to be tested (bootstrapping from scratch v. bootstrapping from the installed ghc).

I'll try updating the bootstrap compiler to 6.8.3. May take some time to untangle the dependencies and get a minimal bootstrap compiler running.

Can anyone who has experienced this problem tell me if it happens on Tiger (10.4) or is it only seen on Leopard (10.5)? I have a Tiger/ppc machine but no access to a Leopard/ppc machine.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 5 years ago by dluke@…

Replying to gwright@…:

Can anyone who has experienced this problem tell me if it happens on Tiger (10.4) or is it only seen on Leopard (10.5)? I have a Tiger/ppc machine but no access to a Leopard/ppc machine.

If it would be helpful, I can set you up with a shell account on my colocated 10.5 ppc machine.

comment:6 in reply to: ↑ 5 Changed 5 years ago by gwright@…

Replying to dluke@…:

Replying to gwright@…:

Can anyone who has experienced this problem tell me if it happens on Tiger (10.4) or is it only seen on Leopard (10.5)? I have a Tiger/ppc machine but no access to a Leopard/ppc machine.

If it would be helpful, I can set you up with a shell account on my colocated 10.5 ppc machine.

That may be helpful. I've been able to bootstrap 6.10.1 using a 6.10.1 binary on Tiger; the same bootstrap compiler may work for Leopard. I should have a minimal dependency bootstrap compiler done later today; if we could set up an account I could test over the weekend. Thanks!

comment:7 Changed 5 years ago by ryandesign@…

  • Description modified (diff)

comment:8 in reply to: ↑ 3 Changed 5 years ago by ryandesign@…

Replying to macports@…:

I also posted this error to glasgow-haskell-users@… and they pointed out a suspiciously similar error in their error tracking system:

http://hackage.haskell.org/trac/ghc/ticket/2380

Duplicate of #15142.

comment:9 Changed 5 years ago by gwright@…

  • Status changed from assigned to closed
  • Resolution set to duplicate

I'll close this as a dup and note further changes under #15142.

comment:10 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.