New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #17522 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

"configure: error: cannot find Python library path" during opensync installation - wrong path

Reported by: kjell@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: opensync, python, "No such file or directory", "annot find Python library path" Cc:
Port: opensync 0.22_2

Description

Using OS X Version 10.5.5 (Systemversion: Mac OS X 10.5.5 (9F33) Kernelversion: Darwin 9.5.0) on an 2.4 GHz Intel Core 2 Duo with 4GB RAM.


I am trying to install opensync which terminates with:

checking for Python include path... /opt/local/include/python2.5/ checking for Python library path... find: /opt/local/lib/python/config/: No such file or directory find: /opt/local/lib/python/: No such file or directory configure: error: cannot find Python library path Error: Status 1 encountered during processing. Executing: /opt/local/bin/port install opensync


Printout from installation: Port command started with PID 94038 Fetching opensync Verifying checksum(s) for opensync Extracting opensync Configuring opensync Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_opensync/work/libopensync-0.22" && ./configure --prefix=/opt/local --disable-dependency-tracking --enable-python=2.5 --libexecdir=/opt/local/sbin " returned error 1 Command output: checking if the linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) is GNU ld... no checking whether the /usr/bin/g++-4.0 linker (/usr/libex ec/gcc/i686-apple-darwin9/4.0.1/ld) supports shared libraries... yes checking for /usr/bin/g++-4.0 option to produce PIC... -fno-common checking if /usr/bin/g++-4.0 PIC flag -fno-common works... yes checking if /usr/bin/g++-4.0 static flag -static works... no checking if /usr/bin/g++-4.0 supports -c -o file.o... yes checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) supports shared libraries... yes checking dynamic linker characteristics... darwin9.5.0 dyld checkin g how to hardcode library paths into programs... immediate appending configuration tag "F77" to libtool checking for bison... bison -y checking for pkg-config... /opt/local/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for XML... yes configure: Checking to see if we can build Python bindings checking whether /opt/local/bin/python2.5 version >= 2.5... yes checking for version... 2.5 checking for platform... darwin checking for script directory... ${prefix}/lib/python2.5/si te-packages checking for extension module directory... ${exec_prefix}/lib/python2.5/site-packages checking for headers required to compile python extensions... found checking for swig... /opt/local/bin/swig checking for SWIG version... 1.3.36 configure: SWIG executable is '/opt/local/bin/swig' configure: SWIG library directory is '/opt/local/share/swig/1.3.36' checking for Python include path... /opt/local/include/python2.5/ checking for Python library path... find: /opt/local/lib/python/config/: No such file or directory find: /opt/local/lib/python/: No such file or directory configure: error: cannot find Python library path Error: Status 1 encountered during processing. Executing: /opt/local/bin/port install opensync

Change History

comment:1 Changed 5 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to duplicate

Dupe of #17523.

comment:2 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.