New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #21111 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

automake failure when installing ghostscript @8.70

Reported by: jwz@… Owned by: takanori@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc: mww@…
Port: automake ghostscript

Description

I have done the Migration fire drill.

port clean ghostscript; port -f uninstall ghostscript; port install ghostscript
--->  Cleaning ghostscript
--->  Computing dependencies for ghostscript
--->  Fetching ghostscript
--->  Verifying checksum(s) for ghostscript
--->  Extracting ghostscript
--->  Applying patches to ghostscript
--->  Configuring ghostscript
Error: Target org.macports.configure returned: autoconf failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/work/ghostscript-8.70" && autoreconf -fvi " returned error 1
Command output: autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal  --output=aclocal.m4t
This Perl not built to support threads
Compilation failed in require at /opt/local/share/automake-1.11/Automake/ChannelDefs.pm line 23.
BEGIN failed--compilation aborted at /opt/local/share/automake-1.11/Automake/ChannelDefs.pm line 26.
Compilation failed in require at /opt/local/share/automake-1.11/Automake/Configure_ac.pm line 26.
BEGIN failed--compilation aborted at /opt/local/share/automake-1.11/Automake/Configure_ac.pm line 26.
Compilation failed in require at /opt/local/bin/aclocal line 39.
BEGIN failed--compilation aborted at /opt/local/bin/aclocal line 39.
autoreconf: aclocal failed with exit status: 255

Error: Status 1 encountered during processing.
Exit 1

Change History

comment:1 Changed 5 years ago by ryandesign@…

  • Owner changed from macports-tickets@… to takanori@…
  • Keywords snowleopard added
  • Port set to ghostscript
  • Summary changed from ghostscript @8.70 doesn't install on MacOS 10.6 to ghostscript @8.70 doesn't install on Mac OS X 10.6

So it's the same error as #21098 but this time the error persists after rebuilding ports.

Can you tell us about your perl? What perl ports are installed? For what architectures?

comment:2 Changed 5 years ago by snc@…

Have you completed the Migration upgrade to 1.8.0, successfully cleaning and rebuilding all your ports?

comment:3 Changed 5 years ago by jwz@…

Yes, I have done the Migration thing.

What do you want to know about Perl? I think it's all default-ly:

port installed | grep perl
  ImageMagick @6.5.5-0_0+jbig+lcms+perl+q32 (active)
  perl5 @5.8.9_0 (active)
  perl5.8 @5.8.9_3 (active)

comment:4 Changed 4 years ago by jmr@…

  • Status changed from new to closed
  • Cc mww@… added
  • Summary changed from ghostscript @8.70 doesn't install on Mac OS X 10.6 to automake failure when installing ghostscript @8.70
  • Keywords snowleopard removed
  • Resolution set to worksforme
  • Port changed from ghostscript to automake ghostscript

Can't reproduce.

Note: See TracTickets for help on using tickets.