New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #21941 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

mesa 7.6, unable to build on tiger 10.4.11

Reported by: hamham4001@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: mesa 7.6 build failure tiger Cc:
Port: mesa

Description (last modified by ryandesign@…) (diff)

I'm trying to install wine, and I get an error while wine builds mesa. I am using a intel-based macbook on OS X 10.4.11. (This ticket is very similar to Ticket #21801, but i am installing for the first time instead of upgrading)
I've tried to uninstall macport, and reinstall everything, but the same thing happens.
Is there a way I can chose to install older versions of mesa instead of the newest one when i install wine?

Thanks a lot!

--->  Building mesa
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_mesa/work/Mesa-7.6" && /usr/bin/make -j2 default INSTALL_DIR=/opt/local CC=/usr/bin/gcc-4.0 CXX=/usr/bin/g++-4.0 " returned error 2
Command output: _*gluPartialDisk
_*gluPerspective
_*gluPickMatrix
_*gluProject
_*gluPwlCurve
_*gluQuadricCallback
_*gluQuadricDrawStyle
_*gluQuadricNormals
_*gluQuadricOrientation
_*gluQuadricTexture
_*gluScaleImage
_*gluSphere
_*gluTessBeginContour
_*gluTessBeginPolygon
_*gluTessCallback
_*gluTessEndContour
_*gluTessEndPolygon
_*gluTessNormal
_*gluTessProperty
_*gluTessVertex
_*gluUnProject
_*gluUnProject4
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: internal link edit command failed
mklib: Installing libGLU.1.3.dylib libGLU.1.dylib libGLU.dylib in ../../../lib
mv: rename libGLU.1.3.dylib to ../../../lib/libGLU.1.3.dylib: No such file or directory
make[4]: *** [../../../lib/libGLU.dylib] Error 1
make[3]: *** [default] Error 1
make[2]: *** [default] Error 1
make[1]: *** [subdirs] Error 1
make: *** [default] Error 1

Error: The following dependencies failed to build: mesa xorg-libXcursor xorg-renderproto xrender xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto xorg-libXxf86vm xorg-xf86vidmodeproto
Error: Status 1 encountered during processing.

Change History

comment:1 in reply to: ↑ description Changed 5 years ago by ryandesign@…

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Replying to hamham4001@…:

I'm trying to install wine, and I get an error while wine builds mesa. I am using a intel-based macbook on OS X 10.4.11. (This ticket is very similar to Ticket #21801, but i am installing for the first time instead of upgrading)

It's exactly the same error, so I'm closing this as a duplicate of #21801.

Is there a way I can chose to install older versions of mesa instead of the newest one when i install wine?

See the InstallingOlderPort how-to.

Also please remember WikiFormatting in the future.

Note: See TracTickets for help on using tickets.