New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #22185 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

openvrml-0.18.3 libxml2 required to build

Reported by: miyasita@… Owned by: raphael@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc:
Port: openvrml

Description

I tried to install OpenVRML, but the port command stopped with error:

% sudo port install openvrml
... snip ...
--->  Configuring openvrml
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_openvrml/work/openvrml-0.18.3" && ./configure --prefix=/opt/local --disable-script-node-javascript --disable-script-node-java --disable-xembed --disable-player --disable-mozilla-plugin --with-x --x-includes=/opt/local/include --x-libraries=/opt/local/lib " returned error 1
Command output: checking if gcj static flag -static works... no
checking if gcj supports -c -o file.o... no
checking if gcj supports -c -o file.o... (cached) no
checking whether the gcj linker (/usr/libexec/gcc/i686-apple-darwin10/4.2.1/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking for gcj... no
checking for javac... javac
checking for gcjh... no
checking for javah... javah
checking for jar... jar
checking for doxygen... no
checking for Rez... /usr/bin/Rez
checking if the compiler supports the gcc visibility attribute... yes
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... -D_THREAD_SAFE
checking ltdl.h usability... yes
checking ltdl.h presence... yes
checking for ltdl.h... yes
checking jni.h usability... no
checking jni.h presence... no
checking for jni.h... no
checking for boost_thread-mt library... yes
checking for pkg-config... /opt/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for XML... no
configure: error: in `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_openvrml/work/openvrml-0.18.3':
configure: error: libxml not found
See `config.log' for more details.

Error: Status 1 encountered during processing.

I thought that openvrml port needs libxml2 port. I added "port:libxml2" into the Portfile of openvrml (see the following patch file) and I succeed to install openvrml.

--- Portfile.orig	2009-10-21 19:47:30.000000000 +0900
+++ Portfile	2009-10-21 19:47:19.000000000 +0900
@@ -28,6 +28,7 @@
                         port:jpeg \
                         port:fontconfig \
                         port:mesa \
+			port:libxml2 \
                         path:lib/pkgconfig/sdl.pc:libsdl
 depends_build           port:pkgconfig

In addition, I had to overcome another bug(?) in the sources of openvrml. I had to add "#include <boost/function/function0.hpp>" into src/libopenvrml/openvrml/scene.h with the following patch:

--- scene.h.orig	2009-10-21 20:26:59.000000000 +0900
+++ scene.h	2009-10-21 20:27:19.000000000 +0900
@@ -26,6 +26,7 @@
 #   include <openvrml/bad_url.h>
 #   include <openvrml/node.h>
 #   include <boost/thread.hpp>
+#   include <boost/function/function0.hpp>
 
 namespace openvrml {
 

But this patch must go to openvrml developers.

Attachments

patch-Portfile.diff (632 bytes) - added by raphael@… 5 years ago.
patch-scene.h.diff (336 bytes) - added by raphael@… 5 years ago.

Change History

comment:1 Changed 5 years ago by macsforever2000@…

  • Owner changed from macports-tickets@… to raphael@…

comment:2 in reply to: ↑ description Changed 5 years ago by raphael@…

Replying to miyasita@…:

I thought that openvrml port needs libxml2 port. I added "port:libxml2" into the Portfile of openvrml (see the following patch file) and I succeed to install openvrml.

Sorry, I obviously forgot to declare a dependency on libxml2.

In addition, I had to overcome another bug(?) in the sources of openvrml. I had to add "#include <boost/function/function0.hpp>" into src/libopenvrml/openvrml/scene.h

This seems to be caused by a change in boost-1.40.0. The OpenVRML developers already fixed this problem for future versions of OpenVRML. In the meantime, we can use your patch. The patch file and a patch for the portfile is attached.

I'm the maintainer of this port. Can anybody with commit rights please commit my changes and close this ticket?

Changed 5 years ago by raphael@…

Changed 5 years ago by raphael@…

comment:3 Changed 4 years ago by macsforever2000@…

  • Status changed from new to closed
  • Resolution set to fixed

Committed revision r60121.

Note: See TracTickets for help on using tickets.