New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #22335 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Problem building libical

Reported by: macports@… Owned by: jonas@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc:
Port: libical

Description

This appears the be a duplicate of the closed ticket #22089, except that, unlike the reporter of the earlier bug, I was not able to resolve it by a clean rebuild. A clean rebuild produced the same results as before. This is under Snow Leopard and XCode 3.2.1:

Attachments

bug.txt (2.1 KB) - added by macports@… 4 years ago.
build error
install-output.txt (12.0 KB) - added by macports@… 4 years ago.

Change History

Changed 4 years ago by macports@…

build error

comment:1 Changed 4 years ago by jmr@…

  • Owner changed from macports-tickets@… to jonas@…
  • Port set to libical

comment:2 follow-up: ↓ 3 Changed 4 years ago by jmr@…

Did you upgrade from an older OS release, and if so, did you follow the Migration instructions?

comment:3 in reply to: ↑ 2 Changed 4 years ago by macports@…

Replying to jmr@…:

Did you upgrade from an older OS release, and if so, did you follow the Migration instructions?

I did upgrade from Leopard, and was unaware of the procedure given in the Migration instructions. Unfortunately, after a complete clean and uninstall, as recommended in those instructions, the build of libical still results in the same error I originally reported.

comment:4 Changed 4 years ago by jmr@…

Given that it installs fine here, and the other person found that it worked after cleaning, I really have to suspect that you haven't cleaned up the old build. Attach the full output of sudo port -d install libical.

Changed 4 years ago by macports@…

comment:5 Changed 4 years ago by macports@…

Thanks for your help. I share your suspicion that the old build is not completely cleaned up, but I don't know what's left after:

sudo port clean all
sudo port -f uninstall installed

I have attached the output from 'sudo port -d install libical'.

comment:6 Changed 4 years ago by jmr@…

The port was doing something a bit strange; try again after r60148 hits rsync (though I still don't know why it would fail for you but not me).

comment:7 Changed 4 years ago by macports@…

It is indeed strange. As you say, something must not have cleared, because after completely deleting all MacPorts files and then re-installing MacPorts, the libical build succeeds. This ticket can be closed.

comment:8 Changed 4 years ago by macsforever2000@…

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.