New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #23732 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Linkage problem with libknewstuff and/or libattica following KDE 4.4 update

Reported by: jonesc@… Owned by: snc@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: sharky@…, lang@…, macports@…, mayace.cysque@…, kahuna@…, ryandesign@…
Port: kdebase4

Description (last modified by macsforever2000@…) (diff)

Hi,

After updating to KDE 4.4, trying to start dolphin now results in the error below.

I've tried cleaning and reinstalling all KDE4 packages, no luck. The ports I have installed are

Chris-Jones-Macbook-Pro /opt/local/lib > sudo port list installed | grep -i kde
attica                         @0.1.2          kde/attica
kdebase4                       @4.4.0          kde/kdebase4
kdebase4-runtime               @4.4.0          kde/kdebase4-runtime
kdelibs4                       @4.4.0          kde/kdelibs4
kdepimlibs4                    @4.4.0          kde/kdepimlibs4
oxygen-icons                   @4.4.0          kde/oxygen-icons

If I check my /opt/local/lib area, I do have libattica.0.dylib

Chris-Jones-Macbook-Pro /opt/local/lib > ls -l libattica.* libknewstuff*
-rwxr-xr-x  2 root  admin  478264 15 Feb 20:34 libattica.0.1.2.dylib
lrwxr-xr-x  1 root  admin      21 15 Feb 20:34 libattica.0.dylib -> libattica.0.1.2.dylib
lrwxr-xr-x  1 root  admin      17 15 Feb 20:34 libattica.dylib -> libattica.0.dylib
-rwxr-xr-x  2 root  admin  646264 15 Feb 21:01 libknewstuff2.4.4.0.dylib
lrwxr-xr-x  1 root  admin      25 15 Feb 21:13 libknewstuff2.4.dylib -> libknewstuff2.4.4.0.dylib
lrwxr-xr-x  1 root  admin      21 15 Feb 21:13 libknewstuff2.dylib -> libknewstuff2.4.dylib
-rwxr-xr-x  2 root  admin  636184 15 Feb 21:04 libknewstuff3.4.4.0.dylib
lrwxr-xr-x  1 root  admin      25 15 Feb 21:13 libknewstuff3.4.dylib -> libknewstuff3.4.4.0.dylib
lrwxr-xr-x  1 root  admin      21 15 Feb 21:13 libknewstuff3.dylib -> libknewstuff3.4.dylib

Looks like some sort of linking issue between libknewstuff and libattica ?

cheers Chris


Process:         dolphin [45821]
Path:            /Applications/MacPorts/KDE4/dolphin.app/Contents/MacOS/dolphin
Identifier:      dolphin
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [424]

Date/Time:       2010-02-15 21:39:31.321 +0000
OS Version:      Mac OS X 10.6.2 (10C540)
Report Version:  6

Interval Since Last Report:          378827 sec
Crashes Since Last Report:           8
Per-App Crashes Since Last Report:   7
Anonymous UUID:                      3743D1E8-FC5C-4FBA-A77D-40256CD5A0F4

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
 Library not loaded: libattica.0.dylib
 Referenced from: /opt/local/lib/libknewstuff3.4.dylib
 Reason: image not found

Model: MacBookPro5,1, BootROM MBP51.007E.B05, 2 processors, Intel Core 2 Duo, 2.53 GHz, 4 GB, SMC 1.33f8
Graphics: NVIDIA GeForce 9600M GT, NVIDIA GeForce 9600M GT, PCIe, 512 MB
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.91.26)
Bluetooth: Version 2.2.4f3, 2 service, 1 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: ST9500420ASG, 465.76 GB
Serial ATA Device: MATSHITADVD-R   UJ-868
USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8507, 0x24400000
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac  (Apple Inc.), 0x0237, 0x04600000
USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8242, 0x04500000
USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000
USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8213, 0x06110000

Change History

comment:1 Changed 5 years ago by macsforever2000@…

  • Cc sharky@… added
  • Owner changed from macports-tickets@… to snc@…
  • Description modified (diff)
  • Keywords kde4 libknewstuff libattica removed

comment:2 Changed 5 years ago by eatdespain@…

Hi,

solution I applied is the follwing:

vi .profile

And add:

export DYLD_FALLBACK_LIBRARY_PATH=/opt/local/lib:$DYLD_FALLBACK_LIBRARY_PATH 

then run:

open /Applications/MacPorts/KDE4/Amarok.app/

and it should work.

Please, be sure all those paths are right for you

Thanks

comment:3 Changed 5 years ago by jonesc@…

Hi,

Thanks, your work around seems to work if the application is opened from the Terminal, but it does not help if Dolphin is started via finder. Even after logging out and back in I get the same crash.

Chris

comment:4 Changed 5 years ago by snc@…

  • Status changed from new to assigned

We might consider moving the binary to libexec and creating a wrapper script that is launched, setting the environment.

comment:5 Changed 5 years ago by jonesc@…

Just FYI upgraded to KDE 4.4.1 and the problem is still there.

comment:6 Changed 4 years ago by snc@…

I think we want to set LD_LIBRARY_PATH otherwise Apple's libraries will be included first.

comment:7 Changed 4 years ago by lang@…

  • Cc lang@… added

Cc Me!

comment:8 Changed 4 years ago by oldjohn@…

After some obstacles (#22144) it seems that I succeded installing amarok 2.2.0.
If I try to run it from finder it returns the problem with libattica reported here.
Setting DYLD_FALLBACK_LIBRARY_PATH solves this issue.
Now amarok starts up, the splash screen comes up, but then this error box shows up:

Amarok could not find any collection plugins. It is possible that Amarok is installed under the wrong prefix, please fix your installation using:

$ cd /path/to/amarok/source-code/
$ su -c "make uninstall"
$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` && su -c "make install"
$ kbuildsycoca4 --noincremental
$ amarok

More information can be found in the README file. For further assistance join us at #amarok on irc.freenode.net.

Any idea about this?
What are collection plugins?

comment:9 Changed 4 years ago by macports@…

  • Cc macports@… added

Cc Me!

comment:10 Changed 4 years ago by mayace.cysque@…

  • Cc mayace.cysque@… added

Cc Me!

comment:11 Changed 4 years ago by kahuna@…

  • Cc kahuna@… added

Cc Me!

comment:12 in reply to: ↑ description Changed 4 years ago by ryandesign@…

  • Status changed from assigned to closed
  • Cc ryandesign@… added
  • Resolution set to fixed

Replying to jonesc@…:

Library not loaded: libattica.0.dylib
Referenced from: /opt/local/lib/libknewstuff3.4.dylib

The underlying problem was fixed by #23538. I bumped attica's revision in r67242 so it gets rebuilt following this change.

Note: See TracTickets for help on using tickets.