New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #24140 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

py-wxpython 2.8.9.2 building error

Reported by: aprillafontaine@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: jwa@…
Port: py-wxpython

Description (last modified by macsforever2000@…) (diff)

Hello I have a PowerPC Dual G5

Error by installing this software py-wxpython

regards jessica

DEBUG: Searching for dependency: python24
DEBUG: Found Dependency: receipt exists for python24
DEBUG: Searching for dependency: wxWidgets
DEBUG: Found Dependency: receipt exists for wxWidgets
DEBUG: Executing org.macports.main (py-wxpython)
DEBUG: Skipping completed org.macports.fetch (py-wxpython)
DEBUG: Skipping completed org.macports.checksum (py-wxpython)
DEBUG: setting option extract.cmd to /usr/bin/bzip2
DEBUG: Skipping completed org.macports.extract (py-wxpython)
DEBUG: Skipping completed org.macports.patch (py-wxpython)
DEBUG: Skipping completed org.macports.configure (py-wxpython)
--->  Building py-wxpython
DEBUG: Executing org.macports.build (py-wxpython)
DEBUG: Environment: WXPORT='mac' MACOSX_DEPLOYMENT_TARGET='10.5' PATH='/opt/local/lib/wx-devel/bin:/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' UNICODE='1'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-wxpython/work/wxPython-src-2.8.9.2/wxPython" && /opt/local/bin/python2.4 setup.py build'
WARNING: WXWIN not set in environment. Assuming '..'
Found wx-config: /opt/local/bin/wx-config
    Using flags:  --toolkit=mac --unicode=yes --version=2.8
Preparing CORE...
Preparing GLCANVAS...
Preparing STC...
Preparing GIZMOS...
running build
running build_py
copying wx/__version__.py -> build.unicode/lib.macosx-10.5-ppc-2.4/wx
copying wx/build/build_options.py -> build.unicode/lib.macosx-10.5-ppc-2.4/wx/build
package init file 'wx/tools/XRCed/plugins/__init__.py' not found (or not a regular file)
package init file 'wx/tools/XRCed/plugins/__init__.py' not found (or not a regular file)
running build_ext
building '_gdi_' extension
/usr/bin/gcc-4.0 -fno-strict-aliasing -mno-fused-madd -fno-common -fno-common -dynamic -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -DSWIG_TYPE_TABLE=_wxPython_table -DSWIG_PYTHON_OUTPUT_TUPLE -DWXP_USE_THREAD=1 -UNDEBUG -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXMAC__ -Iinclude -Isrc -I/opt/local/lib/wx/include/mac-unicode-release-2.8 -I/opt/local/include/wx-2.8 -I/opt/local/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4 -c src/mac/_gdi_wrap.cpp -o build.unicode/temp.macosx-10.5-ppc-2.4/src/mac/_gdi_wrap.o -O3
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for C/ObjC but not for C++
src/mac/_gdi_wrap.cpp: In function 'wxPalette* new_wxPalette(const wxArrayInt&, const wxArrayInt&, const wxArrayInt&)':
src/mac/_gdi_wrap.cpp:2884: warning: comparison between signed and unsigned integer expressions
src/mac/_gdi_wrap.cpp:2884: warning: comparison between signed and unsigned integer expressions
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_new_GraphicsBitmap(PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:26306: error: 'wxGraphicsBitmap' was not declared in this scope
src/mac/_gdi_wrap.cpp:26306: error: 'result' was not declared in this scope
src/mac/_gdi_wrap.cpp:26310: error: expected primary-expression before ')' token
src/mac/_gdi_wrap.cpp:26310: error: expected `;' before 'new'
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_delete_GraphicsBitmap(PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:26322: error: 'wxGraphicsBitmap' was not declared in this scope
src/mac/_gdi_wrap.cpp:26322: error: 'arg1' was not declared in this scope
src/mac/_gdi_wrap.cpp:26322: error: expected primary-expression before ')' token
src/mac/_gdi_wrap.cpp:26322: error: expected `;' before numeric constant
src/mac/_gdi_wrap.cpp:26333: error: expected type-specifier before 'wxGraphicsBitmap'
src/mac/_gdi_wrap.cpp:26333: error: expected `>' before 'wxGraphicsBitmap'
src/mac/_gdi_wrap.cpp:26333: error: expected `(' before 'wxGraphicsBitmap'
src/mac/_gdi_wrap.cpp:26333: error: expected primary-expression before '>' token
src/mac/_gdi_wrap.cpp:26333: error: expected `)' before ';' token
src/mac/_gdi_wrap.cpp:26335: error: type '<type error>' argument given to 'delete', expected pointer
src/mac/_gdi_wrap.cpp: In function 'PyObject* NullGraphicsBitmap_get()':
src/mac/_gdi_wrap.cpp:28283: error: 'wxNullGraphicsBitmap' was not declared in this scope
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_GraphicsContext_CreateBitmap(PyObject*, PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:28813: error: 'wxGraphicsBitmap' was not declared in this scope
src/mac/_gdi_wrap.cpp:28813: error: expected `;' before 'result'
src/mac/_gdi_wrap.cpp:28839: error: 'result' was not declared in this scope
src/mac/_gdi_wrap.cpp:28839: error: 'const class wxGraphicsContext' has no member named 'CreateBitmap'
src/mac/_gdi_wrap.cpp:28842: error: expected type-specifier before 'wxGraphicsBitmap'
src/mac/_gdi_wrap.cpp:28842: error: expected `)' before 'wxGraphicsBitmap'
src/mac/_gdi_wrap.cpp:28842: error: expected `)' before ';' token
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_GraphicsContext_DrawGraphicsBitmap(PyObject*, PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:30211: error: 'wxGraphicsBitmap' was not declared in this scope
src/mac/_gdi_wrap.cpp:30211: error: 'arg2' was not declared in this scope
src/mac/_gdi_wrap.cpp:30251: error: expected type-specifier before 'wxGraphicsBitmap'
src/mac/_gdi_wrap.cpp:30251: error: expected `>' before 'wxGraphicsBitmap'
src/mac/_gdi_wrap.cpp:30251: error: expected `(' before 'wxGraphicsBitmap'
src/mac/_gdi_wrap.cpp:30251: error: expected primary-expression before '>' token
src/mac/_gdi_wrap.cpp:30251: error: expected `)' before ';' token
src/mac/_gdi_wrap.cpp:30273: error: 'class wxGraphicsContext' has no member named 'DrawGraphicsBitmap'
src/mac/_gdi_wrap.cpp:30273: error: expected `)' before 'const'
src/mac/_gdi_wrap.cpp:30273: error: expected `)' before ';' token
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_PenList_AddPen(PyObject*, PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:33140: warning: 'AddPen' is deprecated (declared at /opt/local/include/wx-2.8/wx/gdicmn.h:516)
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_PenList_RemovePen(PyObject*, PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:33178: warning: 'RemovePen' is deprecated (declared at /opt/local/include/wx-2.8/wx/gdicmn.h:517)
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_BrushList_AddBrush(PyObject*, PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:33271: warning: 'AddBrush' is deprecated (declared at /opt/local/include/wx-2.8/wx/gdicmn.h:526)
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_BrushList_RemoveBrush(PyObject*, PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:33309: warning: 'RemoveBrush' is deprecated (declared at /opt/local/include/wx-2.8/wx/gdicmn.h:527)
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_FontList_AddFont(PyObject*, PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:33461: warning: 'AddFont' is deprecated (declared at /opt/local/include/wx-2.8/wx/gdicmn.h:539)
src/mac/_gdi_wrap.cpp: In function 'PyObject* _wrap_FontList_RemoveFont(PyObject*, PyObject*, PyObject*)':
src/mac/_gdi_wrap.cpp:33499: warning: 'RemoveFont' is deprecated (declared at /opt/local/include/wx-2.8/wx/gdicmn.h:540)
src/mac/_gdi_wrap.cpp: In function 'void* _p_wxGraphicsBitmapTo_p_wxGraphicsObject(void*)':
src/mac/_gdi_wrap.cpp:40941: error: 'wxGraphicsBitmap' was not declared in this scope
src/mac/_gdi_wrap.cpp:40941: error: expected primary-expression before 'void'
src/mac/_gdi_wrap.cpp:40941: error: expected `)' before 'void'
src/mac/_gdi_wrap.cpp: In function 'void* _p_wxGraphicsBitmapTo_p_wxObject(void*)':
src/mac/_gdi_wrap.cpp:41154: error: 'wxGraphicsBitmap' was not declared in this scope
src/mac/_gdi_wrap.cpp:41154: error: expected primary-expression before 'void'
src/mac/_gdi_wrap.cpp:41154: error: expected `)' before 'void'
error: command '/usr/bin/gcc-4.0' failed with exit status 1
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-wxpython/work/wxPython-src-2.8.9.2/wxPython" && /opt/local/bin/python2.4 setup.py build " returned error 1
DEBUG: Backtrace: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-wxpython/work/wxPython-src-2.8.9.2/wxPython" && /opt/local/bin/python2.4 setup.py build " returned error 1
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for py-wxpython): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History

comment:1 Changed 4 years ago by macsforever2000@…

  • Description modified (diff)
  • Cc jwa@… added
  • Priority changed from Low to Normal
  • Owner changed from macports-tickets@… to mww@…
  • Milestone MacPorts 1.8.3 deleted
  • Keywords py-wxpython 2.8.9.2 removed
  • Type changed from request to defect
  • Port changed from py-wxpython 2.8.9.2 to py-wxpython

comment:2 follow-ups: ↓ 3 ↓ 4 Changed 4 years ago by macsforever2000@…

So are you running Mac OS X 10.5? What version of Xcode do you have?

Have you tried to install py26-wxpython instead? It is preferred because python 2.4 is very old.

comment:3 in reply to: ↑ 2 Changed 4 years ago by aprillafontaine@…

Replying to macsforever2000@…:

So are you running Mac OS X 10.5? What version of Xcode do you have?

Have you tried to install py26-wxpython instead? It is preferred because python 2.4 is very old.

Hello O.K. I have installed the new version and it works. I have MAC OS X 10.5 and i use Xcode 3.1.3

comment:4 in reply to: ↑ 2 Changed 4 years ago by pgroce+macports@…

Replying to macsforever2000@…:

So are you running Mac OS X 10.5? What version of Xcode do you have?

Have you tried to install py26-wxpython instead? It is preferred because python 2.4 is very old.

This is true; regrettably, Python 2.4 is still in use in many production systems. (Admittedly, most of them run Linux, but it's quite convenient to test on your development platform.)

I'd like to see this bug fixed, so I can manage the Pythons I need to test against in Macports. Despite that, though, 2.4 is old enough to consider deprecating.

comment:5 Changed 3 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to worksforme

Can't reproduce.

Note: See TracTickets for help on using tickets.