New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #24885 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

gcc45 build fails on Snow Leopard

Reported by: chuck@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: snowleopard Cc:
Port: gcc45

Description

I have two machines running Snow Leopard. One is an upgrade, the other is a new machine. I was able to install gcc45 on the new machine, but not on the other which upgraded to Snow Leopard from Leopard. I was able to build gcc44 there, however. Here is the error part of the build log:

Comparing stages 2 and 3
warning: gcc/cc1-checksum.o differs
warning: gcc/cc1obj-checksum.o differs
warning: gcc/cc1objplus-checksum.o differs
warning: gcc/cc1plus-checksum.o differs
Bootstrap comparison failure!
x86_64-apple-darwin10/i386/libgomp/.libs/bar.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/barrier.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/env.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/iter.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/iter_ull.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/lock.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/loop.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/loop_ull.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/ordered.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/parallel.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/proc.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/sections.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/single.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/task.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/team.o differs
x86_64-apple-darwin10/i386/libgomp/.libs/work.o differs
x86_64-apple-darwin10/i386/libgomp/bar.o differs
x86_64-apple-darwin10/i386/libgomp/barrier.o differs
x86_64-apple-darwin10/i386/libgomp/env.o differs
x86_64-apple-darwin10/i386/libgomp/iter.o differs
x86_64-apple-darwin10/i386/libgomp/iter_ull.o differs
x86_64-apple-darwin10/i386/libgomp/lock.o differs
x86_64-apple-darwin10/i386/libgomp/loop.o differs
x86_64-apple-darwin10/i386/libgomp/loop_ull.o differs
x86_64-apple-darwin10/i386/libgomp/ordered.o differs
x86_64-apple-darwin10/i386/libgomp/parallel.o differs
x86_64-apple-darwin10/i386/libgomp/proc.o differs
x86_64-apple-darwin10/i386/libgomp/sections.o differs
x86_64-apple-darwin10/i386/libgomp/single.o differs
x86_64-apple-darwin10/i386/libgomp/task.o differs
x86_64-apple-darwin10/i386/libgomp/team.o differs
x86_64-apple-darwin10/i386/libgomp/work.o differs
make[2]: *** [compare] Error 1
make[1]: *** [stage3-bubble] Error 2
make: *** [bootstrap] Error 2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc45/work/build" && /usr/bin/make -j2 bootstrap " returned error 2
DEBUG: Backtrace: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc45/work/build" && /usr/bin/make -j2 bootstrap " returned error 2
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for gcc45): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Any help would be greatly appreciated.

-- Chuck Allison

Change History

comment:1 Changed 4 years ago by ryandesign@…

  • Owner changed from macports-tickets@… to mww@…
  • Keywords snowleopard added; gcc45 snow leopard mac os x 10.6.3 removed

Don't forget to Cc the port maintainer when filing tickets.

comment:2 Changed 4 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #24664, please search before filing new tickets.

Note: See TracTickets for help on using tickets.