New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #25968 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

MacPorts bash completion leaves tty echo off after tail -f

Reported by: jeremyhu@… Owned by: raimue@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: michael@…, drew@…
Port: bash-completion

Description (last modified by jeremyhu@…) (diff)

Enable the following in your bashrc:

if [ "${BASH-no}" != "no" ]; then
    if [ -f /opt/local/etc/bash_completion ]; then
        . /opt/local/etc/bash_completion
    fi
fi

Run the following using tab-completion to complete the path to system.log:

$ tail -f /var/log/system.log

Hit control-c to end the tail.

You will notice that tty echo is off at this point.

Change History

comment:1 Changed 4 years ago by jeremyhu@…

  • Owner changed from macports-tickets@… to raimue@…
  • Description modified (diff)

comment:2 Changed 4 years ago by jeremyhu@…

  • Port set to bash-completion

Note that this happens with no scripts in /opt/local/etc/bash_completion.d

comment:3 Changed 4 years ago by jeremyhu@…

This happens with /bin/bash, but it works fine with /opt/local/bin/bash

comment:4 Changed 4 years ago by raimue@…

  • Status changed from new to assigned

I was able to reproduce this, yet I don't see anything where bash-completion would set flags on the tty. I suspect this is a readline bug, but can't confirm it yet.

comment:5 Changed 4 years ago by michael@…

  • Cc michael@… added

Cc Me!

comment:6 Changed 4 years ago by drew@…

I have found this same issue to exist with the stock bash and bash-completion as provided by Homebrew (http://mxcl.github.com/homebrew/).

comment:7 Changed 4 years ago by drew@…

  • Cc drew@… added

Cc Me!

comment:8 Changed 4 years ago by jeremyhu@…

Right, it's an issue with bash-completion rather than bash itself.

comment:9 Changed 3 years ago by raimue@…

  • Status changed from assigned to closed
  • Resolution set to fixed

I am unable to reproduce this issue with /bin/bash and bash-completion @1.3_0.

Note: See TracTickets for help on using tickets.