New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #30959 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Atlas 3.9.47_0+gcc44 CacheEdge DETECTION error

Reported by: boydb@… Owned by: jameskyle@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: vince@…
Port: atlas

Description

OS 10.6.8 on Quad-Core Mac Pro failed to update atlas from 3.9.37_0 to 3.9.47_0.

Snip from install log:

:info:build    DONE  STAGE 2-1-1 at 09:46
:info:build 
:info:build 
:info:build    BEGIN STAGE 2-1-2: CacheEdge DETECTION at 09:46
:info:build make -f Makefile INSTALL_LOG/atlas_cacheedge.h pre=d 2>&1 | ./xatlas_tee INSTALL_LOG/dMMCACHEEDGE.LOG
:info:build make[1]: *** [build] Error 255
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/atlas/work/atlas-3.9.47/build'
:info:build make: *** [build] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/atlas/work/atlas-3.9.47/build'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/atlas/work/atlas-3.9.47/build" && /usr/bin/make -w build " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for atlas): org.macports.install org.macports.build org.macports.destroot
:notice:build Log for atlas is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/atlas/main.log

Attachments

main.log (1.1 MB) - added by boydb@… 3 years ago.
atlas_main.log

Change History

Changed 3 years ago by boydb@…

atlas_main.log

comment:1 Changed 3 years ago by macsforever2000@…

  • Owner changed from macports-tickets@… to jameskyle@…
  • Cc vince@… added

Try using the gcc45 variant.

comment:2 Changed 3 years ago by vince@…

Thanks, I was about to propose the same thing

comment:3 Changed 3 years ago by vince@…

  • Status changed from new to closed
  • Resolution set to duplicate

Actually a duplicate of #30748. Something is wrong with the Xcode install (lacks stdint.h).

Note: See TracTickets for help on using tickets.