New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #34335 (closed defect: worksforme)

Opened 2 years ago

Last modified 13 months ago

Inkscape crashes with CLI PDF export

Reported by: dusan.maliarik@… Owned by: devans@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc: suv-sf@…
Port: inkscape

Description (last modified by ryandesign@…) (diff)

I'm trying to use Inkscape to do SVG to PDF conversion from a script. I'm using the -A argument to export PDF, and -f to specify the source SVG. With the same SVG data, the UI export works, but the CLI export crashes with

** Message: Error: Inkscape encountered an internal error and will close now.
Abort trap: 6

Backtrace:

(gdb) bt
#0  0x00007fff8d0e1ce2 in __pthread_kill ()
#1  0x00007fff91c217d2 in pthread_kill ()
#2  0x00007fff91c12a7a in abort ()
#3  0x00007fff912777bc in abort_message ()
#4  0x00007fff91274fcf in default_terminate ()
#5  0x00007fff8933f1cd in _objc_terminate ()
#6  0x00007fff91275001 in safe_handler_caller ()
#7  0x00007fff9127505c in std::terminate ()
#8  0x00007fff91276152 in __cxa_throw ()
#9  0x000000010023291b in Inkscape::Extension::Output::save ()
#10 0x000000010000255f in do_export_ps_pdf ()
#11 0x0000000100003868 in sp_process_file_list ()
#12 0x0000000100004318 in sp_main_console ()
#13 0x0000000100004fe9 in main ()

Attachments

drawing.svg (2.6 KB) - added by dusan.maliarik@… 2 years ago.

Change History

Changed 2 years ago by dusan.maliarik@…

comment:1 Changed 2 years ago by dusan.maliarik@…

...and of course the same thing works perfectly fine on a linux server...

comment:2 Changed 2 years ago by ryandesign@…

  • Owner changed from macports-tickets@… to devans@…
  • Description modified (diff)

comment:3 Changed 2 years ago by suv-sf@…

  • Cc suv-sf@… added

Cc Me!

comment:4 Changed 2 years ago by suv-sf@…

Works for me with Inkscape 0.48.3.1 installed via MacPorts on OS X 10.7.4 (Xcode 4.3.2), as well as with current trunk builds (compiled outside of MacPorts).

From the attached SVG file:

inkscape:version="0.48+devel r10591 custom"

Do you have a custom version of the port 'inkscape-devel' installed on your Mac? Or was the file generated on a different system using an outdated version of the (unstable) development branch of Inkscape?

What is the output of 'inkscape --version' on your Mac?
Does the crash also occur with the current stable version 0.48.3.1?
Does it also crash if you run the command manually (without the script)?

inkscape -A "Desktop/drawing-cli.pdf" -f "Desktop/drawing.svg"

comment:5 Changed 13 months ago by devans@…

  • Status changed from new to closed
  • Resolution set to worksforme

Problem can not be reproduced with current inkscape versions:

Inkscape 0.48.4 r9939 (Jul 31 2013)
Inkscape 0.48+devel r12478 custom (Aug 15 2013)
Note: See TracTickets for help on using tickets.