New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #37214 (closed defect: fixed)

Opened 22 months ago

Last modified 21 months ago

Maxima not playing well with SBCL 1.1.2

Reported by: kirc0076@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: easieste@…, gwright@…, kuba@…, rwc@…, tkbrekken@…
Port: maxima sbcl

Description

I upgraded my outdated packages, and SBCL was one of them. Tried to load maxima, didn't work. Tried to uninstall both maxima and sbcl, then reinstall maxima. Still unable to run maxima.

$ rmaxima
fatal error encountered in SBCL pid 93700:
can't load .core for different runtime, sorry


Welcome to LDB, a low-level debugger for the Lisp runtime environment.
ldb> 

Log attached.

Attachments

maxima.log (2.7 KB) - added by kirc0076@… 22 months ago.

Change History

comment:1 Changed 22 months ago by ryandesign@…

  • Cc easieste@…, gwright@…, kuba@… added

comment:2 Changed 22 months ago by jmr@…

IIRC it's necessary to increment maxima's revision every time sbcl's version is updated.

Changed 22 months ago by kirc0076@…

comment:3 follow-up: ↓ 6 Changed 22 months ago by easieste@…

Hmm. I'll look into fixing Maxima. It should certainly be possible to patch Maxima to dynamically compile and load its fasls if there is newer version of sbcl present. Such a patch should be trivial if Maxima is using ASDF.

Last edited 22 months ago by easieste@… (previous) (diff)

comment:4 Changed 22 months ago by rwc@…

  • Cc rwc@… added

Cc Me!

comment:5 Changed 22 months ago by tkbrekken@…

  • Cc tkbrekken@… added

Cc Me!

comment:6 in reply to: ↑ 3 ; follow-up: ↓ 8 Changed 22 months ago by mcq@…

Replying to easieste@…:

Hmm. I'll look into fixing Maxima. It should certainly be possible to patch Maxima to dynamically compile and load its fasls if there is newer version of sbcl present. Such a patch should be trivial if Maxima is using ASDF.

There might be a miscommunication here. This ticket is reporting a new problem.

The problem of having to manually uninstall and reinstall maxima after sbcl update is an old problem. I believe it's reported in multiple tickets already.

The new problem is that doing that (uninstalling and reinstalling maxima) no longer works. I was not using maxima for a few months, so I just encountered it today, with

sbcl @1.1.2_0 (active)

and

maxima @5.28.0_1+xmaxima (active)

Unfortunately, I already deleted all my old versions so I'm not sure of the last time the uninstalling / reinstalling trick worked.

UPDATE ON 19 DEC 2012:

When I posted the above, I forgot that I had maxima installed on another machine where I had not cleaned out old versions. Today I noticed that and set SBCL back to SBCL @1.1.1_0 without success. Then I set SBCL back to @1.1.0_0 and ... Success! It plays nicely with maxima@5.28.0_1+xmaxima! So that will be my temporary solution for now.

(TLDR: Success with SBCL @1.1.0_0!)

Last edited 22 months ago by mcq@… (previous) (diff)

comment:7 Changed 22 months ago by macsforever2000@…

  • Port changed from maxima, sbcl to maxima sbcl

comment:8 in reply to: ↑ 6 ; follow-up: ↓ 9 Changed 21 months ago by and.damore@…

Replying to mcq@…:

The new problem is that doing that (uninstalling and reinstalling maxima) no longer works. I was not using maxima for a few months, so I just encountered it today, with

sbcl @1.1.2_0 (active)

I just stumbled into this, my guess is you're installing maxima binary package that is being built with a different version of sbcl on the build server.

Try upgrading sbcl, uninstalling maxima and then reinstalling maxima using -s option in order to build it from source.

comment:9 in reply to: ↑ 8 Changed 21 months ago by kirc0076@…

Replying to and.damore@…:

Try upgrading sbcl, uninstalling maxima and then reinstalling maxima using -s option in order to build it from source.

This fixed the problem. Thanks.

Is there a way to modify the portfile to force building from source?

Last edited 21 months ago by kirc0076@… (previous) (diff)

comment:10 Changed 21 months ago by macsforever2000@…

Confirmed. sbcl was updated since maxima. So now maxima needs to be rebuilt on the buildbot - I'm trying to figure out how to do that without modifying the portfile.

comment:11 Changed 21 months ago by macsforever2000@…

  • Status changed from new to closed
  • Resolution set to fixed

I realized that maxima was broken for everyone currently and increased the revision in r101312.

comment:12 Changed 21 months ago by jmr@…

There was no miscommunication; I said in comment:2 that the revision needed to be bumped, and easieste replied that he would rather find a way to make that unnecessary. Since that solution doesn't seem to have appeared yet, bumping the revision was of course the correct short-term fix.

Note: See TracTickets for help on using tickets.