New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #612 (closed defect: duplicate)

Opened 13 years ago

Last modified 3 months ago

mysql update

Reported by: bchesneau@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: darwinports-bugs@…, mike.mclean@…
Port:

Description

new stable release of mysql : 4.0.13 version

4.0.13 is the new recommended production release.

Attachments

patch-mysql-20030603 (2.5 KB) - added by bchesneau@… 13 years ago.
Portfile patch
config.log (101.5 KB) - added by bchesneau@… 13 years ago.
config.log with gcc3.3

Change History

Changed 13 years ago by bchesneau@…

Portfile patch

comment:1 Changed 13 years ago by bchesneau@…

  • Cc darwinports-bugs@… added

comment:2 Changed 13 years ago by waqar@…

I guess we can invalidate bug#399, and does this fix the problem described in #390?

Last edited 3 months ago by ryandesign@… (previous) (diff)

comment:3 Changed 13 years ago by bchesneau@…

yes it invalidate bug#399 and fix bug#390 indeed

comment:4 Changed 13 years ago by bchesneau@…

* Bug 399 has been marked as a duplicate of this bug. *

comment:5 Changed 13 years ago by waqar@…

* Bug 498 has been marked as a duplicate of this bug. *

comment:6 Changed 13 years ago by bchesneau@…

bug in compilation on 10.2.6 :

[namshub:dports/devel/glib] benoitc# port -dv install mysql +server
DEBUG: com.apple.package registered provides 'package', a pre-existing procedure. Target override will not be provided
DEBUG: Executing darwin provides darwin
DEBUG: Executing server provides server
DEBUG: com.apple.package registered provides 'package', a pre-existing procedure. Target override will not be provided
DEBUG: com.apple.package registered provides 'package', a pre-existing procedure. Target override will not be provided
DEBUG: Found Dependency: receipt: /opt/local/var/db/dports/receipts/DarwinPortsStartup-1.0.bz2
DEBUG: Found Dependency: receipt: /opt/local/var/db/dports/receipts/dlcompat-20030522.bz2
DEBUG: Skipping completed com.apple.main (mysql)
DEBUG: Skipping completed com.apple.fetch (mysql)
DEBUG: Skipping completed com.apple.checksum (mysql)
DEBUG: Skipping completed com.apple.extract (mysql)
DEBUG: Skipping completed com.apple.patch (mysql)
--->  Configuring mysql
DEBUG: Executing com.apple.configure (mysql)
DEBUG: Assembled command: 'cd "/opt/darwinports/dports/databases/mysql/work/mysql-4.0.13" && LDFLAGS=-L/opt/local/lib\ -lncurses CPPFLAGS=-I/opt/local/include ./configure --prefix=/opt/local --localstatedir=/opt/local/var/db/mysql --sysconfdir=/opt/local/etc --without-bench'
checking build system type... powerpc-apple-darwin6.6
checking host system type... powerpc-apple-darwin6.6
checking target system type... powerpc-apple-darwin6.6
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets ${MAKE}... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for gawk... (cached) awk
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking how to run the C preprocessor... gcc -E
checking "C Compiler version"... "gcc gcc (GCC) 3.3 20030304 (Apple Computer, Inc. build 1435)"
checking "C++ compiler version"... "g++ g++ (GCC) 3.3 20030304 (Apple Computer, Inc. build 1435)"
checking for ranlib... ranlib
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... no
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -p
checking whether ln -s works... yes
checking how to recognise dependant libraries... file_magic Mach-O dynamically linked shared library
checking command to parse /usr/bin/nm -p output... ok
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for ranlib... (cached) ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fno-common
checking if gcc PIC flag -fno-common works... yes
checking if gcc static flag -static works... no
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... unsupported
checking whether stripping libraries is possible... no
checking dynamic linker characteristics... darwin6.6 dyld
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
creating libtool
checking for a BSD-compatible install... /usr/bin/install -c
checking for bison... bison -y
checking for pdftex... no
checking for tex... no
checking "return type of sprintf"... "int"
checking for uname... /usr/bin/uname
checking operating system... Darwin
checking "if we should use 'skip-locking' as default for darwin6.6"... "no"
checking for ln... /bin/ln
checking for ln... /bin/ln
checking for mv... /bin/mv
checking for rm... /bin/rm
checking for cp... /bin/cp
checking for sed... /usr/bin/sed
checking for cmp... /usr/bin/cmp
checking for chmod... /bin/chmod
checking for hostname... /bin/hostname
checking for gnutar... gnutar
checking for perl... /opt/local/bin/perl
checking for ps... /bin/ps
checking "how to check if pid exists"... "/bin/ps p $$PID | grep mysqld > /dev/null"
checking for kill... /bin/kill
checking "for kill switches"... "/bin/kill -0 $$PID > /dev/null 2> /dev/null"
checking for gcc option to accept ANSI C... 
checking if we should use assembler functions... no
checking if we should use RAID... no
checking If we should should enable LOAD DATA LOCAL by default... no
checking for getconf... no
checking for CFLAGS value to request large file support... no
checking for LDFLAGS value to request large file support... no
checking for LIBS value to request large file support... no
checking for _FILE_OFFSET_BITS... no
checking for _LARGEFILE_SOURCE... no
checking for _LARGE_FILES... no
checking for size_t... yes
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required
checking for ANSI C header files... (cached) yes
checking for sys/wait.h that is POSIX.1 compatible... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking float.h usability... yes
checking float.h presence... yes
checking for float.h... yes
checking floatingpoint.h usability... no
checking floatingpoint.h presence... no
checking for floatingpoint.h... no
checking ieeefp.h usability... no
checking ieeefp.h presence... no
checking for ieeefp.h... no
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking for memory.h... (cached) yes
checking pwd.h usability... yes
checking pwd.h presence... yes
checking for pwd.h... yes
checking select.h usability... no
checking select.h presence... no
checking for select.h... no
checking for stdlib.h... (cached) yes
checking stddef.h usability... yes
checking stddef.h presence... yes
checking for stddef.h... yes
checking for strings.h... (cached) yes
checking for string.h... (cached) yes
checking synch.h usability... no
checking synch.h presence... no
checking for synch.h... no
checking sys/mman.h usability... yes
checking sys/mman.h presence... yes
checking for sys/mman.h... yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking netinet/in.h usability... yes
checking netinet/in.h presence... yes
checking for netinet/in.h... yes
checking arpa/inet.h usability... yes
checking arpa/inet.h presence... yes
checking for arpa/inet.h... yes
checking sys/timeb.h usability... yes
checking sys/timeb.h presence... yes
checking for sys/timeb.h... yes
checking for sys/types.h... (cached) yes
checking sys/un.h usability... yes
checking sys/un.h presence... yes
checking for sys/un.h... yes
checking sys/vadvise.h usability... yes
checking sys/vadvise.h presence... yes
checking for sys/vadvise.h... yes
checking for sys/wait.h... (cached) yes
checking term.h usability... yes
checking term.h presence... yes
checking for term.h... yes
checking for unistd.h... (cached) yes
checking utime.h usability... yes
checking utime.h presence... yes
checking for utime.h... yes
checking sys/utime.h usability... no
checking sys/utime.h presence... no
checking for sys/utime.h... no
checking termio.h usability... no
checking termio.h presence... no
checking for termio.h... no
checking termios.h usability... yes
checking termios.h presence... yes
checking for termios.h... yes
checking sched.h usability... yes
checking sched.h presence... yes
checking for sched.h... yes
checking crypt.h usability... no
checking crypt.h presence... no
checking for crypt.h... no
checking alloca.h usability... no
checking alloca.h presence... no
checking for alloca.h... no
checking sys/ioctl.h usability... yes
checking sys/ioctl.h presence... yes
checking for sys/ioctl.h... yes
checking for floor in -lm... yes
checking for gethostbyname_r in -lnsl_r... no
checking for gethostbyname_r in -lnsl... no
checking for gethostbyname_r... no
checking for setsockopt... yes
checking for yp_get_default_domain... yes
checking for p2open... no
checking for p2open in -lgen... no
checking for bind... yes
checking for crypt in -lcrypt... no
checking for crypt... yes
checking for sem_init... yes
checking if libz with compress... yes
checking if we should use pstack... 
checking for int8... no
checking "LinuxThreads"... "Not found"
checking "DEC threads"... "no"
checking "DEC 3.2 threads"... "no"
checking "SCO threads"... "no"
checking "SCO UnixWare7 native threads"... "no"
checking "OpenUNIX8 native threads"... "no"
checking "Siemens threads"... "no"
checking "Solaris threads"... "no"
checking "named thread libs:"... "no"
checking "for pthread_create in -libc"... "yes"
checking for strtok_r in -lpthread... yes
checking for strtok_r... yes
checking for dlopen in -ldl... yes
checking for unistd.h... (cached) yes
checking for restartable system calls... yes
checking "need of special linking flags"... "none"
checking for gcc option to accept ANSI C... none needed
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for off_t... no
checking for struct stat.st_rdev... no
checking whether time.h and sys/time.h may both be included... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for char... no
checking size of char... 0
configure: error: No size for char type.
A likely cause for this could be that there isn't any
static libraries installed. You can verify this by checking if you have libm.a
in /lib, /usr/lib or some other standard place.  If this is the problem,
install the static libraries and try again.  If this isn't the problem,
examine config.log for possible errors.  If you want to report this, use
'scripts/mysqlbug' and include at least the last 20 rows from config.log!
Error: Target com.apple.configure returned: configure failure: shell command "cd "/opt/darwinports/dports/databases/mysql/work/mysql-4.0.13" && LDFLAGS=-L/opt/local/lib\ -lncurses CPPFLAGS=-I/opt/local/include ./configure --prefix=/opt/local --localstatedir=/opt/local/var/db/mysql --sysconfdir=/opt/local/etc --without-bench" returned error 1
Command output: checking "DEC 3.2 threads"... "no"
Warning: the following items did not execute (for mysql): com.apple.install com.apple.configure com.apple.build
Last edited 3 months ago by ryandesign@… (previous) (diff)

Changed 13 years ago by bchesneau@…

config.log with gcc3.3

comment:7 Changed 13 years ago by mike.mclean@…

I suggest a new port, databases/mysql4 to handle the 4.x series of MySQL separately from the 3.23.x series.

comment:8 Changed 13 years ago by mike.mclean@…

  • Cc mike.mclean@… added

comment:9 Changed 13 years ago by eric@…

  • Owner changed from eric@… to darwinports-bugs@…

comment:10 Changed 13 years ago by mij@…

Please do not do this. The 3.x tree of mysql is still being updated, as well as still being used by a whole pile of people (including myself). If you want a port with version 4, please make a mysql4 port.

  • jim

comment:11 Changed 13 years ago by mike.mclean@…

This is what I suggested, leaving the databases/mysql directory for 3.23.x series and creating a new port in databases/mysql4 for the 4 series. I too use 3.23.x.

I also requested to "reopen" bug #399, which is a .x update to 3.23. I uploaded a Portfile that will correctly build and install 3.23.57

Last edited 3 months ago by ryandesign@… (previous) (diff)

comment:12 Changed 13 years ago by bchesneau@…

  • Status changed from new to closed
  • Resolution set to duplicate

* This bug has been marked as a duplicate of 768 *

Note: See TracTickets for help on using tickets.