Ticket #8205 (closed defect: fixed)
py-lint broken due to incorrect py-logilab version and missing dependency
|Reported by:||apm13@…||Owned by:||macports-tickets@…|
There are probably other packages in the ports tree which depend on the 0.14 version of py-logilab that is curently available, however the py-lint 0.10 which is in the tree requires py-logilab 0.15 (logilab common) and ASTNG 0.15 (see http://www.logilab.org/projects/pylint/0.10). As a result it is necessary that either pylint be downgraded to 0.9 (which requires 0.14 of logilab common, and ATSNG which is not available from ports), or that the logilab common package be upgraded. Thanks.