Ticket #36098: akonadi.patch

File akonadi.patch, 1.8 KB (added by kurtjaeke@…, 8 years ago)
  • ports/devel/akonadi/Portfile

    a b PortSystem 1.0 
    55PortGroup           kde4    1.1
    66
    77name                akonadi
    8 version             1.7.2
     8version             1.8.0
    99categories          devel kde kde4
    1010maintainers         nomaintainer
    1111license             LGPL-2+
    homepage http://pim.kde.org/akonadi/ 
    1717master_sites        kde:stable/${name}/src/
    1818use_bzip2           yes
    1919
    20 checksums           sha1    6aef88b46f8f7ce2dbdfb3641bce2d0bb733f181 \
    21                     rmd160  f6c0b4173fd7ea4b60a9e311984e35ce638e8ec7
     20checksums           sha256 1644040ccc62c39325127cd32d19e846f62ffb1efa90b8d5e6a137a2545fa66d \
     21                    rmd160 20954cfa63965b2e757c781585e4bacde87b0d5c
    2222
    2323depends_lib-append  port:soprano \
    24                                         port:boost \
     24                    port:boost \
    2525                    port:shared-mime-info
    2626
     27configure.args-append  -DPOSTGRES_PATH=Off
     28
    2729depends_run-append  path:libexec/mysqld:mysql5-server
     30configure.args-append  -DDATABASE_BACKEND=MYSQL
     31
     32variant sqlite description {Use sqlite backend instead of MySQL} {
     33                    depends_run-delete path:libexec/mysqld:mysql5-server
     34                    configure.args-delete  -DDATABASE_BACKEND=MYSQL
     35                    configure.args-append  -DDATABASE_BACKEND=SQLITE
     36}
    2837
    29 patchfiles          patch-server-src-nepomuk-queryserviceclient.h.diff
    3038post-patch {
    3139    # fix '#include "utils.h"' -> "src/utils.h" to avoid a conflict
    3240    # with the 'utils.h' header installed by the cdparanoia port
    post-patch { 
    3745    }
    3846}
    3947
    40 configure.args-append   -DDATABASE_BACKEND=MYSQL -DPOSTGRES_PATH=Off
    41 
    4248platform darwin 9 {
    4349    if {[info exists universal_target] && ${universal_target} == "10.4"} {
    4450# Needed if compiling for 10.4 universal on 10.5