source: trunk/dports/databases/libgda5/Portfile @ 111742

Last change on this file since 111742 was 111742, checked in by devans@…, 6 years ago

libgda5: remove legacy variants and related notes introduced 20120130.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 4.9 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 111742 2013-09-30 15:01:06Z devans@macports.org $
3
4PortSystem      1.0
5
6name            libgda5
7set gname       libgda
8version         5.1.2
9revision        3
10license         {GPL-2 LGPL}
11
12set branch      [join [lrange [split ${version} .] 0 1] .]
13description     GDA provides uniform access to different kinds of data sources.
14long_description \
15                GNU Data Access (GDA) is an attempt to provide \
16                uniform access to different kinds of data sources \
17                (databases, information servers, mail spools, etc).
18maintainers     jwa devans openmaintainer
19categories      databases gnome
20platforms       darwin
21homepage        http://www.gnome-db.org/
22distname        libgda-${version}
23master_sites    gnome:sources/${gname}/${branch}/
24use_xz          yes
25
26checksums       rmd160  36b06a9e07a2e8d81d2d093021712fa2d8b361f0 \
27                sha256  59c4416a151297a406091fcfe7af781ea88af3381d10b365ba73b1eb8e23b6c5
28
29depends_skip_archcheck gnome-settings-daemon
30
31depends_build   port:pkgconfig \
32                port:intltool \
33                port:gnome-doc-utils \
34                port:gtk-doc
35
36depends_lib     port:desktop-file-utils \
37                port:readline \
38                path:bin/dot:graphviz \
39                port:gtksourceview2 \
40                port:goocanvas \
41                port:iso-codes \
42                port:libsoup \
43                port:libtool \
44                port:gobject-introspection
45
46depends_run     port:gnome-settings-daemon \
47                port:yelp
48
49default_variants +bdb
50
51# Don't do intltool's INTLTOOL_PERL dance
52use_autoreconf  yes
53autoreconf.args -fvi
54
55#
56# use embedded libsqlite3 rather than the system version
57# to avoid dlopen 'Can't find file libsqlite3.so' errors
58#
59
60configure.args  --with-bdb=${prefix} \
61                --enable-system-sqlite=no \
62                --enable-introspection \
63                --disable-silent-rules \
64                --with-ldap=no \
65                --without-mysql \
66                --without-postgres \
67                --without-oracle \
68                --without-firebird \
69                --without-java \
70                --without-jni
71
72#                --without-mdb
73
74use_parallel_build no
75
76variant mysql5 \
77    description {support for current MySQL 5.x} {
78    depends_lib-append  path:bin/mysql_config5:mysql5
79    configure.env-append    \
80        MYSQL_CONFIG=${prefix}/lib/mysql5/bin/mysql_config
81    configure.args-delete   --without-mysql
82    configure.args-append   --with-mysql=${prefix}/lib/mysql5
83    configure.cppflags-append   "-I${prefix}/include/mysql5/mysql"
84}
85
86variant postgresql83 conflicts postgresql84 postgresql90 postgresql91 \
87    description {support for PostgreSQL 8.3.x} {
88    configure.cppflags-append   "-I${prefix}/include/postgresql83"
89    depends_lib-append  port:postgresql83
90    configure.args-delete   --without-postgres
91    configure.args-append   --with-postgres=${prefix}/lib/postgresql83
92}
93
94variant postgresql84 conflicts postgresql83 postgresql90 postgresql91 \
95    description {support for PostgreSQL 8.4.x} {
96    configure.cppflags-append   "-I${prefix}/include/postgresql84"
97    depends_lib-append  port:postgresql84
98    configure.args-delete   --without-postgres
99    configure.args-append   --with-postgres=${prefix}/lib/postgresql84
100}
101
102variant postgresql90 conflicts postgresql83 postgresql84 postgresql91 \
103    description {support for PostgreSQL 9.0.x} {
104    configure.cppflags-append   "-I${prefix}/include/postgresql90"
105    depends_lib-append  port:postgresql90
106    configure.args-delete   --without-postgres
107    configure.args-append   --with-postgres=${prefix}/lib/postgresql90
108}
109
110variant postgresql91 conflicts postgresql83 postgresql84 postgresql90 \
111    description {support for PostgreSQL 9.1.x} {
112    configure.cppflags-append   "-I${prefix}/include/postgresql91"
113    depends_lib-append  port:postgresql91
114    configure.args-delete   --without-postgres
115    configure.args-append   --with-postgres=${prefix}/lib/postgresql91
116}
117
118variant bdb description {support for Berkeley DB} {
119#
120# prefer Berkeley DB 4.7 over 4.6
121# and depend on it if 4.6 is not installed
122# if both are installed configure will select 4.7
123# otherwise look for 4.6
124#
125    if ([file exists ${prefix}/include/db52/db.h]) {
126        depends_lib-append port:db52
127    } elseif ([file exists ${prefix}/include/db46/db.h])  {
128        depends_lib-append port:db46
129    } elseif ([file exists ${prefix}/include/db47/db.h])  {
130        depends_lib-append port:db47
131    } elseif ([file exists ${prefix}/include/db48/db.h])  {
132        depends_lib-append port:db48
133    } elseif ([file exists ${prefix}/include/db51/db.h])  {
134        depends_lib-append port:db51
135    }
136}
137
138default_variants    +bdb
139
140post-activate {
141    system "${prefix}/bin/gtk-update-icon-cache -f -t ${prefix}/share/icons/hicolor"
142    system "${prefix}/bin/update-desktop-database ${prefix}/share/applications"
143}
144
145livecheck.type      gnome-with-unstable
146livecheck.name      ${gname}
Note: See TracBrowser for help on using the repository browser.