source: trunk/dports/databases/libgda5/Portfile @ 89444

Last change on this file since 89444 was 89444, checked in by jwa@…, 9 years ago

version bump to 5.0.3, change tarball format to xz, change variant names to current, make bdb the default variant, add postgresql91, too

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 4.4 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 89444 2012-01-29 15:50:25Z jwa@macports.org $
3
4PortSystem 1.0
5
6name            libgda5
7conflicts       libgda3 libgda4
8set gname       libgda
9version         5.0.3
10license         {GPL-2 LGPL}
11
12set branch      [join [lrange [split ${version} .] 0 1] .]
13description     GDA provides uniform access to diffent kinds of data sources.
14long_description        \
15    GNU Data Access (GDA) is an attempt to provide \
16    uniform access to different kinds of data sources \
17    (databases, information servers, mail spools, etc).
18maintainers     jwa devans openmaintainer
19categories      databases gnome
20platforms       darwin
21homepage        http://www.gnome-db.org/
22distname        libgda-${version}
23master_sites    gnome:sources/${gname}/${branch}/
24use_xz          yes
25
26checksums           rmd160  b72781633aec2f139ce6fe1d34006513cd58f7ef \
27                    sha256  82d204361b794103c366bb690484d25814bfc653cb97da0dfcf7c0a13409d1cc
28
29#patchfiles      patch-configure.ac.diff
30
31depends_build   port:pkgconfig \
32                port:intltool \
33                port:gnome-doc-utils
34
35depends_lib     port:sqlite3 \
36                path:bin/dot:graphviz \
37                port:gtksourceview2 \
38                port:goocanvas \
39                port:libunique \
40                port:iso-codes \
41                port:libsoup \
42                port:libtool
43
44default_variants        +bdb
45
46#use_autoreconf    yes
47
48configure.perl  ${prefix}/bin/perl
49configure.env-append  INTLTOOL_PERL=${configure.perl}
50
51configure.args  --with-bdb=${prefix} \
52                --enable-system-sqlite \
53                --disable-silent-rules \
54                --disable-introspection \
55                --without-mysql \
56                --without-postgres \
57                --without-oracle \
58                --without-firebird \
59                --without-java \
60                --without-jni
61
62#                --without-mdb
63
64use_parallel_build no
65
66variant mysql5 \
67    description {support for current MySQL 5.x} {
68        depends_lib-append      path:bin/mysql_config5:mysql5
69        configure.env-append    \
70                MYSQL_CONFIG=${prefix}/lib/mysql5/bin/mysql_config
71        configure.args-delete   --without-mysql
72        configure.args-append   --with-mysql=${prefix}/lib/mysql5
73        configure.cppflags-append       "-I${prefix}/include/mysql5/mysql"
74}
75
76variant postgresql83 conflicts postgresql84 postgresql90 postgresql91 \
77    description {support for PostgreSQL 8.3.x} {
78        configure.cppflags-append       "-I${prefix}/include/postgresql83"
79        depends_lib-append      port:postgresql83
80        configure.args-delete   --without-postgres
81        configure.args-append   --with-postgres=${prefix}/lib/postgresql83
82}
83
84variant postgresql84 conflicts postgresql83 postgresql90 postgresql91 \
85    description {support for PostgreSQL 8.4.x} {
86        configure.cppflags-append       "-I${prefix}/include/postgresql84"
87        depends_lib-append      port:postgresql84
88        configure.args-delete   --without-postgres
89        configure.args-append   --with-postgres=${prefix}/lib/postgresql84
90}
91
92variant postgresql90 conflicts postgresql83 postgresql84 postgresql91 \
93    description {support for PostgreSQL 9.0.x} {
94        configure.cppflags-append       "-I${prefix}/include/postgresql90"
95        depends_lib-append      port:postgresql90
96        configure.args-delete   --without-postgres
97        configure.args-append   --with-postgres=${prefix}/lib/postgresql90
98}
99
100variant postgresql91 conflicts postgresql83 postgresql84 postgresql90 \
101    description {support for PostgreSQL 9.1.x} {
102        configure.cppflags-append       "-I${prefix}/include/postgresql91"
103        depends_lib-append      port:postgresql91
104        configure.args-delete   --without-postgres
105        configure.args-append   --with-postgres=${prefix}/lib/postgresql91
106}
107
108variant bdb     description {support for Berkeley DB} {
109#
110# prefer Berkeley DB 4.7 over 4.6
111# and depend on it if 4.6 is not installed
112# if both are installed configure will select 4.7
113# otherwise look for 4.6
114#
115    if ([file exists ${prefix}/include/db52/db.h]) {
116        depends_lib-append port:db52
117    } elseif ([file exists ${prefix}/include/db46/db.h])  {
118        depends_lib-append port:db46
119    } elseif ([file exists ${prefix}/include/db47/db.h])  {
120        depends_lib-append port:db47
121    } elseif ([file exists ${prefix}/include/db48/db.h])  {
122        depends_lib-append port:db48
123    } elseif ([file exists ${prefix}/include/db51/db.h])  {
124        depends_lib-append port:db51
125    }
126}
127
128post-activate {
129    system "${prefix}/bin/gtk-update-icon-cache -f -t ${prefix}/share/icons/hicolor"
130}
131
132livecheck.type          regex
133livecheck.url           http://ftp.gnome.org/pub/GNOME/sources/${gname}/${branch}/
134livecheck.regex         "LATEST-IS-(\\d+(?:\\.\\d+)*)"
Note: See TracBrowser for help on using the repository browser.