source: trunk/dports/gnome/libpeas/Portfile @ 119552

Last change on this file since 119552 was 119552, checked in by devans@…, 6 years ago

libpeas, vte: fix +glade variant so widget catalogs are visable in glade.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 4.2 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:filetype=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 119552 2014-04-30 09:28:54Z devans@macports.org $
3
4PortSystem          1.0
5
6name                libpeas
7version             1.10.0
8revision            1
9license             LGPL-2
10set branch          [join [lrange [split ${version} .] 0 1] .]
11description         libpeas is a GObject-based plugins engine
12long_description    ${description}
13maintainers         devans openmaintainer
14categories          gnome
15platforms           darwin
16homepage            https://wiki.gnome.org/Projects/Libpeas
17master_sites        gnome:sources/${name}/${branch}/
18
19use_xz              yes
20
21checksums           rmd160  c5406a1eae9b67db9a849c10164a3c2797959382 \
22                    sha256  4695bc40e4885a903dbc5ce6a3704392feae63af51fd4da7a3888bb88ca78c47
23
24depends_build       port:pkgconfig \
25                    port:intltool \
26                    port:gnome-common
27
28depends_lib         port:gtk3 \
29                    port:gobject-introspection \
30                    port:seed
31
32# update m4/intltool.m4 and autoreconf
33
34pre-configure {
35    copy -force ${prefix}/share/aclocal/intltool.m4 ${worksrcpath}/m4
36}
37
38use_autoreconf      yes
39autoreconf.args     -fvi
40
41configure.args      --enable-gtk \
42                    --enable-seed \
43                    --disable-glade-catalog \
44                    --disable-python2 \
45                    --disable-python3 \
46                    --disable-silent-rules
47
48variant glade description {Enable glade catalog support} {
49    depends_lib-append      port:glade
50    configure.args-replace  --disable-glade-catalog --enable-glade-catalog
51}
52
53# supports one version each of python2 python3 in parallel
54
55variant python27 description {Use python 2.7} {
56    depends_lib-append          port:py27-gobject3
57    set python_prefix           ${frameworks_dir}/Python.framework/Versions/2.7
58    configure.pkg_config_path   ${python_prefix}/lib/pkgconfig
59    configure.env-append        PYTHON2=${prefix}/bin/python2.7 \
60                                PYTHON2_CONFIG=${python_prefix}/bin/python-config
61    configure.args-replace      --disable-python2 --enable-python2
62}
63
64default_variants +python27
65
66# python3 minimum version is 3.2.0
67
68variant python32 conflicts python33 python34 description {Use python 3.2} {
69    depends_lib-append          port:py32-gobject3
70    set python_prefix           ${frameworks_dir}/Python.framework/Versions/3.2
71    configure.pkg_config_path   ${python_prefix}/lib/pkgconfig
72    configure.python            ${prefix}/bin/python3.2
73    configure.env-append        PYTHON3_CONFIG=${prefix}/bin/python3.2-config
74    configure.cflags-append     -L${python_prefix}/lib
75    configure.args-replace      --disable-python3 --enable-python3
76}
77
78variant python33 conflicts python32 python34 description {Use python 3.3} {
79    depends_lib-append          port:py33-gobject3
80    set python_prefix           ${frameworks_dir}/Python.framework/Versions/3.3
81    configure.pkg_config_path   ${python_prefix}/lib/pkgconfig
82    configure.python            ${prefix}/bin/python3.3
83    configure.env-append        PYTHON3_CONFIG=${prefix}/bin/python3.3-config
84    configure.cflags-append     -L${python_prefix}/lib
85    configure.args-replace      --disable-python3 --enable-python3
86}
87
88variant python34 conflicts python32 python33 description {Use python 3.4} {
89    depends_lib-append          port:py34-gobject3
90    set python_prefix           ${frameworks_dir}/Python.framework/Versions/3.4
91    configure.pkg_config_path   ${python_prefix}/lib/pkgconfig
92    configure.python            ${prefix}/bin/python3.4
93    configure.env-append        PYTHON3_CONFIG=${prefix}/bin/python3.4-config
94    configure.cflags-append     -L${python_prefix}/lib
95    configure.args-replace      --disable-python3 --enable-python3
96}
97
98if {![variant_isset python32] && ![variant_isset python34]} {
99    default_variants +python33
100}
101
102# glade expects catalog modules and libraries to have a .so suffix
103
104post-destroot {
105    if {[variant_isset glade]} {
106        set libdir ${prefix}/lib
107        ln -s ${libdir}/libpeas-gtk-1.0.dylib ${destroot}${libdir}/libpeas-gtk-1.0.so
108    }
109}
110
111post-activate {
112    system "${prefix}/bin/gtk-update-icon-cache-3.0 -f -t ${prefix}/share/icons/hicolor"
113}
114
115livecheck.type  gnome
Note: See TracBrowser for help on using the repository browser.