source: trunk/dports/gnome/vte-gtk2-compat/Portfile @ 122211

Last change on this file since 122211 was 122211, checked in by devans@…, 6 years ago

vte-gtk2-compat: add missing build dependency on gtk-doc.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 2.9 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 122211 2014-07-17 21:01:54Z devans@macports.org $
3
4PortSystem      1.0
5
6name            vte-gtk2-compat
7set gname       vte
8version         0.28.2
9set branch      [join [lrange [split $version .] 0 1] .]
10maintainers     devans openmaintainer
11categories      gnome
12license         LGPL
13platforms       darwin
14description     Terminal widget with improved accessibility and I18N support.
15
16long_description \
17    Terminal widget with improved font, internationalisation and \
18    accessibility support for the GNOME 2 desktop.  Designed to \
19    replace libzvt.
20
21homepage        http://www.gnome.org/
22master_sites    gnome:sources/$gname/$branch/
23use_xz          yes
24
25distname        ${gname}-${version}
26
27checksums       rmd160  8f3396d4e98023b74898e938331917b181964158 \
28                sha256  86cf0b81aa023fa93ed415653d51c96767f20b2d7334c893caba71e42654b0ae
29
30depends_build   port:intltool \
31                port:pkgconfig \
32                port:gtk-doc
33
34depends_lib     port:gtk2
35
36patchfiles      patch-configure.in.diff
37
38# autoreconf to reconfigure with our intltool.m4
39
40use_autoreconf  yes
41autoreconf.args -fvi
42
43configure.args  --with-gtk=2.0 \
44                --disable-introspection \
45                --disable-Bsymbolic \
46                --disable-python
47
48configure.cflags-append -fstrict-aliasing
49
50# default to python27 bindings
51if {![variant_isset python27] && ![variant_isset python26] && ![variant_isset without_python]} {
52    default_variants +python27
53}
54
55variant python27 conflicts python26 \
56description {Build Bindings for Python 2.7} {
57    configure.args-delete --disable-python
58    set python_prefix ${frameworks_dir}/Python.framework/Versions/2.7
59    depends_lib-append port:py27-pygtk
60    configure.python ${prefix}/bin/python2.7
61    configure.pkg_config_path   ${python_prefix}/lib/pkgconfig
62    configure.env               PATH=${python_prefix}/bin:$env(PATH)
63}
64
65variant python26 conflicts python27 \
66description {Build Bindings for Python 2.6} {
67    configure.args-delete --disable-python
68    set python_prefix ${frameworks_dir}/Python.framework/Versions/2.6
69    depends_lib-append port:py26-pygtk
70    configure.python ${prefix}/bin/python2.6
71    configure.pkg_config_path   ${python_prefix}/lib/pkgconfig
72    configure.env               PATH=${python_prefix}/bin:$env(PATH)
73}
74
75variant without_python description {Disable Python support (deprecated, use -pythonXX instead)} {
76    default_variants -python27 -python26
77}
78
79# rename gnome-pty-helper to avoid a conflict with port vte
80
81post-destroot {
82    move ${destroot}${prefix}/libexec/gnome-pty-helper ${destroot}${prefix}/libexec/gnome-pty-helper-0.0
83}
84
85platform darwin 9 {
86    post-patch {
87        reinplace "s| -export-symbols-regex.*||g" \
88            ${worksrcpath}/python/Makefile.in
89        reinplace "s|-export-symbols-regex.*| \\\\|g" \
90            ${worksrcpath}/src/Makefile.in
91    }
92}
93
94livecheck.type  none
Note: See TracBrowser for help on using the repository browser.