source: trunk/dports/gnome/xchat-gnome/Portfile @ 139229

Last change on this file since 139229 was 139229, checked in by jeremyhu@…, 4 years ago

misc: Change port:openssl dependency to path:lib/libssl.dylib:openssl

This should allow usage of libressl as a replacement for openssl in relevant
ports. Not all ports have been tested, but libressl aims for API
compatibility with OpenSSL, so it is expected to work.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 2.5 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 139229 2015-08-08 03:10:35Z jeremyhu@macports.org $
3
4PortSystem          1.0
5
6name                xchat-gnome
7version             0.26.1
8revision            6
9set branch          [join [lrange [split ${version} .] 0 1] .]
10description         xchat-gnome is a frontend to X-Chat.
11long_description    xchat-gnome is a frontend to the popular X-Chat IRC client which is \
12                    designed with the user interface foremost in mind.
13maintainers         nomaintainer
14categories          gnome irc
15license             {GPL-2+ OpenSSLException}
16
17platforms           darwin
18
19homepage            https://wiki.gnome.org/Apps/Xchat-Gnome
20master_sites        gnome:sources/${name}/${branch}/
21
22checksums           md5     c9ce3d6e549736edfc1a1dc0282fb363 \
23                    sha1    85d205baeca5f10be9245c582ae53fbb40a4ef17 \
24                    rmd160  ff2228aa5258a2c5a3bd7c391e83a15b2f030aff
25
26use_bzip2           yes
27
28depends_build       port:pkgconfig \
29                    port:intltool \
30                    port:gnome-doc-utils \
31                    port:gnome-common \
32                    port:autoconf \
33                    port:automake \
34                    port:libtool
35
36depends_lib         port:libgnomeui \
37                    port:libglade2 \
38                    port:gconf \
39                    port:libsexy \
40                    port:libcanberra  \
41                    path:lib/libssl.dylib:openssl \
42                    port:python27 \
43                    port:perl5.16
44
45depends_run         port:yelp
46
47patchfiles          patch-configure.diff
48
49# reconfigure using upstream autogen.sh for intltool 0.51 compatibility
50
51post-patch {
52    xinstall -m 755 ${filespath}/autogen.sh ${worksrcpath}
53}
54
55configure.cmd       ./autogen.sh
56
57configure.python    ${prefix}/bin/python2.7
58configure.perl      ${prefix}/bin/perl5.16
59
60configure.args      --disable-mmx \
61                    --disable-notification \
62                    --enable-compile-warnings=minimum \
63                    --disable-scrollkeeper \
64                    --disable-schemas-install
65
66post-activate    {
67    system "${prefix}/bin/scrollkeeper-update"
68    system "${prefix}/bin/update-desktop-database ${prefix}/share/applications"
69    system "${prefix}/bin/gtk-update-icon-cache -f -t ${prefix}/share/icons/hicolor"
70    system "export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` && \
71        gconftool-2 --makefile-install-rule ${prefix}/etc/gconf/schemas/*.schemas"
72}
73
74livecheck.type      gnome
Note: See TracBrowser for help on using the repository browser.