source: trunk/dports/kde/okular/Portfile @ 115800

Last change on this file since 115800 was 115800, checked in by nicos@…, 7 years ago

kdegraphics4: update to 4.11.5

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 1.8 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 115800 2014-01-11 18:51:59Z nicos@macports.org $
3
4PortSystem          1.0
5PortGroup           kde4   1.1
6
7name                okular
8version             4.11.5
9categories          kde kde4
10license             GPL-2+ LGPL-2+
11maintainers         nicos openmaintainer
12description         Universal document viewer for KDE4.
13long_description    Okular is a universal document viewer based on KPDF for KDE 4. \
14                    This means Okular works on multiple platforms, including but not \
15                    limited to Linux, Windows, Mac OS X, *BSD, etc.
16platforms           darwin
17homepage            http://okular.kde.org/
18master_sites        kde:stable/${version}/src/
19use_xz              yes
20distname            okular-${version}
21checksums           rmd160  fbc76ade4ec97eaf7eb5496a7bb17c6260bfb09f \
22                    sha256  924de02e3baac341ca5036e6989ffa87ee5c21a842ee9e7611f4254cb0999cea
23
24#parttest cannot link to okularpart on Mac, as it is a bundle (.so) file
25patchfiles          patch-OkularPart.diff
26
27#Binaries do not link to openssl, nor use the ssl backend of kdelibs4
28license_noconflict  openssl
29
30depends_lib-append  port:kdelibs4 \
31                    port:oxygen-icons \
32                    port:poppler port:libspectre \
33                    port:djvulibre port:chmlib \
34                    port:ebook-tools port:tiff \
35                    port:qca port:qimageblitz \
36                    port:freetype port:zlib \
37                    port:jpeg
38
39pre-configure {
40    if {![file exists ${prefix}/lib/libpoppler-qt4.dylib]} {
41        return -code error "Poppler must be installed with +qt4\
42                            and +quartz variants"
43    }
44}
45
46livecheck.url       http://kde.mirrors.hoobly.com/stable/
47livecheck.regex     (\\d+(\\.\\d+)+)
Note: See TracBrowser for help on using the repository browser.