source: trunk/dports/python/py-pyface/Portfile @ 106911

Last change on this file since 106911 was 106911, checked in by jmr@…, 6 years ago

Change distribute dependencies back to setuptools and mark py*-distribute replaced_by py*-setuptools (#39237).

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 1.7 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 106911 2013-06-11 14:40:14Z jmr@macports.org $
3
4PortSystem                  1.0
5PortGroup                   python 1.0
6
7name                    py-pyface
8version                 4.2.0
9categories-append       devel
10license                 BSD
11maintainers             gmail.com:jjstickel openmaintainer
12supported_archs         noarch
13
14description             The Enthought pyface package
15long_description        The pyface project contains a toolkit-independent GUI\
16                        abstraction layer, which is used to support the\
17                        "visualization" features of the Traits package.
18platforms               darwin
19homepage                https://github.com/enthought/pyface
20master_sites            http://www.enthought.com/repo/ets/
21distname                pyface-${version}
22
23checksums               rmd160  cd4656b8cab966e6e9ef298a09926b596f1be6cf \
24                        sha256  f2dfc6edaca3e51f3efcdf4e1d85d1cf219e2989959c4683a6cff4f28d4f801c
25
26python.versions         25 26 27
27
28if {$subport != $name} {
29    depends_build-append    port:py${python.version}-setuptools
30    depends_lib-append      port:py${python.version}-traits
31}
32
33variant wx description {Use wxWidgets backend} {
34    if {$subport != $name} {
35        depends_lib-append      port:py${python.version}-wxpython
36    }
37}
38
39variant pyqt4 conflicts pyside description "Qt backend using PyQt4" {
40    if {$subport != $name} {
41        depends_lib-append      port:py${python.version}-pyqt4
42    }
43}
44
45variant pyside conflicts pyqt4 description "Qt backend using PySide" {
46    if {$subport != $name} {
47        depends_lib-append      port:py${python.version}-pyside
48    }
49}
50
51default_variants-append +pyqt4
Note: See TracBrowser for help on using the repository browser.