source: trunk/dports/python/py-pynds/Portfile

Last change on this file was 121548, checked in by ram@…, 3 years ago

python/py-pynds: drop maintainership

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 2.4 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; truncate-lines: t; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:et:sw=4:ts=4:sts=4
2# $Id: Portfile 121548 2014-06-29 19:02:01Z ryandesign@macports.org $
3
4PortSystem              1.0
5PortGroup               python 1.0
6
7name                    py-pynds
8version                 0.7.2
9revision                1
10categories              python science
11platforms               darwin
12maintainers             aronnax
13description             Network Data Server Client Python Wrapper
14long_description \
15    Python wrapper for accessing streamed LIGO data using the Network \
16    Data Server version 2.
17
18homepage                http://www.lsc-group.phys.uwm.edu/daswg/
19master_sites            ${homepage}download/software/source/
20distname                pynds-${version}
21checksums               sha1    0f856f8251c75925ffe4bd1867adf1153d6a28ea \
22                        rmd160  191b7e8a6b2b5fa22111f05194ec8c961903f6dc
23
24python.versions         26 27
25
26if {${name} ne ${subport}} {
27
28    depends_lib-append  port:nds2-client \
29                        port:boost \
30                        port:py${python.version}-numpy
31
32    if { ![file exists ${prefix}/lib/libboost_python-mt.dylib] } {
33        depends_lib-delete port:boost
34    }
35
36    pre-fetch {
37        if { ![file exists ${prefix}/lib/libboost_python-mt.dylib] } {
38            if { [file exists ${prefix}/lib/libboost_system-mt.dylib] } {
39                ui_error "
40****
41**** PyNDS requires port boost installed with variant +python${python.version}.
42**** Please do the following then try installing ${name} again:
43****
44****     sudo port install boost +python${python.version}
45****
46
47"
48            } else {
49                ui_error "
50****
51**** PyNDS requires port boost installed with variant +python${python.version}.
52**** Please do the following then try installing ${name} again:
53****
54****     sudo port install boost +python${python.version}
55****
56
57"
58            }
59            error       "${name} requires boost +python${python.version}"
60        }
61    }
62
63    post-patch {
64        reinplace       "s/boost_python/boost_python-mt/" ${worksrcpath}/setup.py
65    }
66
67    build.env           PYTHON_CFLAGS="-I${prefix}/include/boost" \
68                        CFLAGS="-I${prefix}/include/boost"
69
70}
71
72if {${name} eq ${subport}} {
73    livecheck.type      regex
74    livecheck.url       ${master_sites}
75    livecheck.regex     {pynds-(\d+(?:\.\d+)*).tar.gz}
76} else {
77    livecheck.type      none
78}
Note: See TracBrowser for help on using the repository browser.