source: trunk/dports/ruby/rb-gconf/Portfile @ 74726

Last change on this file since 74726 was 74726, checked in by kimuraw@…, 8 years ago

ruby/rb-gnome: fix #27804, let to work "universal" variant correctly.

Ruby-Gnome2 ports are

rb-atk, rb-gconf, rb-glib2, rb-gnome, rb-gnomecanvas, rb-gnomeprint,
rb-gnomeprintui, rb-gnomevfs, rb-gstreamer, rb-gtk2, rb-gtkglext,
rb-gtkhtml, rb-gtksourceview2, rb-libart, rb-libglade2, rb-libgnome,
rb-pango, rb-poppler, rb-rsvg, rb-vte

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 1.1 KB
Line 
1# $Id: Portfile 74726 2010-12-31 03:39:35Z kimuraw@macports.org $
2
3PortSystem              1.0
4PortGroup               muniversal 1.0
5PortGroup               ruby 1.0
6
7ruby.setup              {gconf ruby-gnome2} 0.90.5 extconf.rb \
8                                { gconf/README gconf/sample } \
9                                sourceforge:ruby-gnome2
10revision                1
11maintainers             kimuraw
12platforms               darwin
13description             Gconf libraries for ruby (a part of Ruby-Gnome2)
14long_description        Gconf libraries for ruby (a part of Ruby-Gnome2)
15categories-append       gnome
16license                 LGPLv2
17checksums               md5 58ee234ef8b121b11de8a245c61cd4a9 \
18                                rmd160 7c96480e366bac2408a3790c355ad517cc0b0023 \
19                                sha1 320fc4c9b65b6494abac894e84013683584acf54
20configure.env   RUBYOPT=-rvendor-specific
21configure.args          --strict gconf
22depends_lib-append      port:gconf port:rb-pkg-config
23distname                ${ruby.project}-all-${version}
24
25# run extconf.rb with each arch `ruby'
26use_parallel_build      no
27post-configure {
28        if {[variant_isset universal]} {
29                foreach arch ${universal_archs} {
30                        system "/usr/bin/arch -${arch} ${ruby.bin} -C ${worksrcpath}-${arch}/gconf extconf.rb --vendor"
31                }
32        }
33}
34
35# for developer only, this test requires rb-gtk2
36#test.run               yes
37test.cmd                ${ruby.bin}
38test.target             -Igconf/src -Igconf/src/lib gconf/tests/unittest.rb
39
Note: See TracBrowser for help on using the repository browser.