source: trunk/dports/ruby/rb-gnome/Portfile @ 74635

Last change on this file since 74635 was 74635, checked in by kimuraw@…, 8 years ago

ruby/rb-gnome: upgrade to 0.90.5

Ruby-Gnome2 ports are

rb-atk, rb-gconf, rb-glib2, rb-gnome, rb-gnomecanvas, rb-gnomeprint,
rb-gnomeprintui, rb-gnomevfs, rb-gstreamer, rb-gtk2, rb-gtkglext,
rb-gtkhtml, rb-gtksourceview2, rb-libart, rb-libglade2, rb-libgnome,
rb-pango, rb-poppler, rb-rsvg, rb-vte

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 1.1 KB
Line 
1# $Id: Portfile 74635 2010-12-25 10:40:07Z kimuraw@macports.org $
2
3PortSystem              1.0
4PortGroup               ruby 1.0
5
6ruby.setup              {gnome ruby-gnome2} 0.90.5 fetch \
7                                { README NEWS } \
8                                sourceforge:ruby-gnome2
9
10maintainers             kimuraw
11platforms               darwin
12description             Ruby-GNOME2 meta port. Ruby-GNOME2 is a set of Ruby \
13                                language bindings for the GNOME 2.0 development environment.
14long_description        Ruby-GNOME2 meta port. Ruby-GNOME2 is a set of Ruby \
15                                language bindings for the GNOME 2.0 development environment.
16categories-append       gnome
17license                 LGPLv2
18depends_lib-append      port:rb-glib2 port:rb-atk port:rb-pango port:rb-gtk2 \
19                                port:rb-gconf port:rb-libgnome port:rb-gnomecanvas \
20                                port:rb-gnomeprint port:rb-gnomeprintui port:rb-gnomevfs \
21                                port:rb-gtkhtml port:rb-gtkglext port:rb-gtksourceview2 \
22                                port:rb-libart port:rb-libglade2 port:rb-rsvg port:rb-poppler
23                                # rb-vte requires X11
24
25distname                ${ruby.project}-all-${version}
26checksums               md5 58ee234ef8b121b11de8a245c61cd4a9 \
27                                rmd160 7c96480e366bac2408a3790c355ad517cc0b0023 \
28                                sha1 320fc4c9b65b6494abac894e84013683584acf54
29
30# install only some documents
31use_configure   no
32destroot                { }     
33
Note: See TracBrowser for help on using the repository browser.