source: trunk/dports/ruby/rb-gnome/files/README.rb-gnome @ 54809

Last change on this file since 54809 was 54809, checked in by kimuraw@…, 11 years ago

ruby/rb-gnome: add README for this port and maintenance script

  • Property svn:keywords set to Id
File size: 1.8 KB
Line 
1$Id: README.rb-gnome 54809 2009-08-02 12:03:11Z kimuraw@macports.org $
2
3= about MacPorts Ruby-GNOME2 ports
4
5== RUBY-GNOME2 Release contents and portfiles status
6
7  * rb-glib2         Ruby/GLib2: GLib 2.0.x or later
8  * rb-atk           Ruby/ATK: ATK 1.0.x or later
9  * rb-pango         Ruby/Pango: Pango 1.1.x or later
10  * rb-gtk2          Ruby/GdkPixbuf2: GTK+ 2.0.x or later
11  * rb-gtk2          Ruby/GTK2: GTK+ 2.0.x or later
12
13rb-gtk2 contains gdkpixbuf2 and gtk2.
14
15  * rb-gconf         Ruby/GConf2: GConf 2.0.x or later
16  * rb-libgnome      Ruby/GNOME2: libgnome-2.0.x, libgnomeui-2.0.x or later
17  * rb-gnomecanvas   Ruby/GnomeCanvas2: libgnomecanvas-2.0.x or later
18  * rb-gnomeprint    Ruby/GnomePrint: libgnomeprint-2.8.x or later
19  * rb-gnomeprintui  Ruby/GnomePrintUI: libgnomeprintui-2.6.x or later
20  * rb-gnomevfs      Ruby/GnomeVFS: GnomeVFS 2.0.x or later
21  * rb-gtkhtml       Ruby/GtkHtml2: GtkHtml2 2.0.x or later
22  * rb-gtkglext      Ruby/GtkGLExt: GtkGLExt 1.0.3 or later
23  * (NOT READY)      Ruby/GtkMozEmbed: GtkMozEmbed (Mozilla 1.7.x or FireFox-1.0.x or later)
24  * (NOT SUPPORT)    Ruby/GtkSourceView: GtkSourceView 1.0.1 or later
25  * rb-libart        Ruby/Libart2: libart_lgpl 2.3.12 or later
26  * rb-libglade2     Ruby/Libglade2: Libglade 2.0.x or later
27  * rb-rsvg          Ruby/RSVG: librsvg 2.8.0 or later
28  * rb-poppler       Ruby/Poppler is a Ruby binding of poppler-glib.
29
30GtkMozEmbed is not found in official ports.
31
32Ruby/GtkSourceView is binding for GtkSourceView 1.0.x. the latest version of
33port:gtksourceview is 1.8.5.
34
35=== Experimental / Incomplete:
36
37  * rb-gstreamer     Ruby/GStreamer: GStreamer 0.10.x or later
38  * rb-gtksourceview2 Ruby/GtkSourceView2: GtkSourceView 2.0.0 or later
39  * (NOT READY)      Ruby/GooCanvas: GooCanvas 0.8.0 or later
40
41=== Depricated
42
43  * (N/A)            Ruby/Libgda: libgda 1.0.3 or later
44  * (N/A)            Ruby/PanelApplet: gnome-panel 2.6.0 or later (deprecated since 0.16.0)
45
Note: See TracBrowser for help on using the repository browser.