source: trunk/dports/security/policykit/Portfile @ 138278

Last change on this file since 138278 was 138278, checked in by devans@…, 4 years ago

policykit: update to version 0.113, important security updates.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 2.8 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:filetype=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 138278 2015-07-03 21:31:45Z devans@macports.org $
3
4PortSystem          1.0
5PortGroup           gobject_introspection 1.0
6
7name                policykit
8version             0.113
9description         PolicyKit is an application-level toolkit for defining and \
10                    handling the policy that allows unprivileged processes to \
11                    speak to privileged processes
12long_description    ${description}
13maintainers         devans openmaintainer
14categories          security
15platforms           darwin
16license             LGPL-2+
17homepage            http://www.freedesktop.org/Software/polkit
18master_sites        http://www.freedesktop.org/software/polkit/releases/
19
20distname            polkit-${version}
21
22checksums           rmd160  661b0a678f7c770c213404db3af604935fdb25bc \
23                    sha256  e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81
24
25depends_build-append \
26                    port:pkgconfig \
27                    port:intltool \
28                    port:gtk-doc \
29                    port:autoconf \
30                    port:automake \
31                    port:libtool
32
33depends_lib         path:lib/pkgconfig/glib-2.0.pc:glib2 \
34                    port:mozjs17
35
36gobject_introspection yes
37
38patchfiles          patch-configure.ac.diff
39
40pre-patch {
41    if {${os.platform} eq "darwin" && ${os.major} < 10} {
42        patchfiles-append patch-fdatasync.diff
43        reinplace "s|security/pam|pam/pam|" ${worksrcpath}/configure.ac \
44            ${worksrcpath}/src/polkitagent/polkitagenthelper-pam.c \
45            ${worksrcpath}/src/programs/pkexec.c
46    }
47}
48
49# reconfigure using upstream autogen.sh for intltool 0.51 compatibility
50
51post-patch {
52    xinstall -m 755 ${filespath}/autogen.sh ${worksrcpath}
53}
54
55configure.cmd       ./autogen.sh
56
57configure.cflags-append -I/usr/include
58configure.ldflags-append -L/usr/lib
59
60configure.args      --with-authfw=pam \
61                    --with-pam-prefix=/etc/pam.d \
62                    --with-pam-module-dir=/usr/lib/pam \
63                    --with-mozjs=mozjs-17.0 \
64                    --enable-systemd=no \
65                    --disable-silent-rules \
66                    --disable-test \
67                    --enable-man-pages \
68                    --disable-gtk-doc
69
70destroot.keepdirs   ${destroot}${prefix}/etc/polkit-1/localauthority \
71                    ${destroot}${prefix}/var/lib/polkit-1
72
73variant docs description {Build API docs using gtk-doc} {
74        configure.args-delete --disable-gtk-doc
75        depends_build-append  port:gtk-doc
76}
77
78add_users           polkituser group=polkituser realname=Policy\ Kit
79
80livecheck.type      regex
81livecheck.url       ${master_sites}
82livecheck.regex     "polkit-(\\d+(?:\\.\\d+)*)${extract.suffix}"
Note: See TracBrowser for help on using the repository browser.