source: trunk/dports/sysutils/apt-rpm/files/patch-rpmsense.diff @ 28177

Last change on this file since 28177 was 28177, checked in by afb@…, 12 years ago

minor version update for testing version

  • lots of patches accepted upstream :-)
  • added distcheck for download directory
File size: 1012 bytes
  • ./apt-pkg/rpm/rpmhandler.cc

    old new  
    6060#define rpmxxInitIterator(a,b,c,d) rpmdbInitIterator(a,b,c,d)
    6161#endif
    6262
     63#if RPM_VERSION >= 0x040409 && !defined(_RPMEVR_INTERNAL)
     64// rpmevr.h/evrFlags_e
     65#define RPMSENSE_ANY 0
     66#define RPMSENSE_MISSINGOK (1 << 19)
     67#endif
     68
    6369// An attempt to deal with false zero epochs from repomd. With older rpm's we
    6470// can only blindly trust the repo admin created the repository with options
    6571// suitable for those versions. For rpm >= 4.2.1 this is linked with
  • ./apt-pkg/rpm/rpmversion.cc

    old new  
    3232#include <rpm/rpmds.h>
    3333#endif
    3434
     35#if RPM_VERSION >= 0x040409 && !defined(_RPMEVR_INTERNAL)
     36// rpmevr.h/evrFlags_e
     37#define RPMSENSE_ANY 0
     38#endif
     39
    3540rpmVersioningSystem rpmVS;
    3641
    3742// rpmVS::rpmVersioningSystem - Constructor                             /*{{{*/
Note: See TracBrowser for help on using the repository browser.