source: trunk/dports/sysutils/rpm/files/patch-configure.diff @ 5177

Last change on this file since 5177 was 5177, checked in by ssen, 16 years ago

Hack the configure script to test for <python2.3/Python.h>
Still need to rationalize that with 10.3 layout

  • Property svn:eol-style set to native
File size: 1.2 KB
RevLine 
[5177]1--- configure.orig      Tue Feb  3 11:10:23 2004
2+++ configure   Tue Feb  3 11:21:37 2004
3@@ -12543,6 +12543,37 @@
4     WITH_PYTHON_VERSION="2.2"
5   else
6 
7+       echo $ac_n "checking for python 2.3""... $ac_c" 1>&6
8+       echo "configure:12517: checking for python 2.3" >&5
9+       if test "$cross_compiling" = yes; then
10+           withval=yes
11+       else
12+           cat > conftest.$ac_ext <<EOF
13+#line 12522 "configure"
14+#include "confdefs.h"
15+
16+#include <python2.3/Python.h>
17+main() {
18+       exit(strncmp("2.3", PY_VERSION, 3));
19+}
20+EOF
21+           if { (eval echo configure:12530: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
22+               then
23+               withval=yes
24+           else
25+               echo "configure: failed program was:" >&5
26+               cat conftest.$ac_ext >&5
27+               rm -fr conftest*
28+               withval=no
29+           fi
30+           rm -fr conftest*
31+       fi
32+
33+       echo "$ac_t""$withval" 1>&6
34+       if test $withval = yes ; then
35+           WITH_PYTHON_VERSION="2.3"
36+       else
37+
38     echo $ac_n "checking for python 1.5.2""... $ac_c" 1>&6
39 echo "configure:12548: checking for python 1.5.2" >&5
40     if test "$cross_compiling" = yes; then
41@@ -12574,7 +12605,7 @@
42       WITH_PYTHON_VERSION="1.5"
43     fi
44   fi
45-
46+  fi
47 fi
48 
49 if test -n "$WITH_PYTHON_VERSION" ; then
Note: See TracBrowser for help on using the repository browser.