source: trunk/dports/sysutils/terminator/Portfile

Last change on this file was 142815, checked in by jmr@…, 20 months ago

various ports: remove redundant clearing of python.link_binaries_suffix, the portgroup now handles this

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 2.7 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 142815 2015-11-24 03:22:35Z ryandesign@macports.org $
3
4PortSystem              1.0
5PortGroup               python 1.0
6
7name                    terminator
8version                 0.98
9categories              sysutils
10platforms               darwin
11maintainers             ryandesign openmaintainer
12license                 GPL-2
13supported_archs         noarch
14
15description             multiple terminal emulator
16
17long_description        ${name} lets you open multiple terminal emulators in \
18                        a single window.
19
20homepage                http://gnometerminator.blogspot.com/p/introduction.html
21master_sites            http://launchpad.net/terminator/trunk/${version}/+download
22dist_subdir             ${name}
23
24checksums               rmd160  cddb24240b74fba3eb6694d9d4aaff11329a14b6 \
25                        sha256  0a6d8c9ffe36d67e60968fbf2752c521e5d498ceda42ef171ad3e966c02f26c1
26
27if {![variant_isset python26] && ![variant_isset python27]} {
28    if {[file exists ${frameworks_dir}/Python.framework/Versions/2.6/lib/python2.6/site-packages/gtk-2.0/vtemodule.so]} {
29        default_variants +python26
30    } else {
31        default_variants +python27
32        variant_set python27
33    }
34}
35
36variant python26 conflicts python27 description {Use Python 2.6} {}
37if {[variant_isset python26]} {
38    python.default_version 26
39}
40
41variant python27 conflicts python26 description {Use Python 2.7} {}
42if {[variant_isset python27]} {
43    python.default_version 27
44}
45
46depends_build-append    port:intltool
47
48depends_lib-append      port:vte-gtk2-compat \
49                        port:hicolor-icon-theme \
50                        port:py${python.version}-keybinder \
51                        port:py${python.version}-notify-python
52
53post-patch {
54    reinplace -E "s|^#!/usr/bin/env python|#!${python.bin}|" ${worksrcpath}/${name}
55}
56
57pre-configure {
58    if {![file exists ${python.pkgd}/gtk-2.0/vtemodule.so]} {
59        ui_error "To install ${name} with the +python${python.version} variant, vte must be installed with the +python${python.version} variant."
60        return -code error "incompatible vte installation"
61    }
62}
63
64post-destroot {
65    foreach manpage {man1/terminator.1 man5/terminator_config.5} {
66        ln -s ${python.prefix}/share/man/${manpage} ${destroot}${prefix}/share/man/${manpage}
67    }
68   
69    set docdir ${destroot}${prefix}/share/doc/${name}
70    xinstall -d ${docdir}
71    xinstall -m 644 -W ${worksrcpath} \
72        COPYING \
73        ChangeLog \
74        README \
75        ${docdir}
76}
77
78livecheck.type          regex
79livecheck.url           http://launchpad.net/terminator/+download
80livecheck.regex         /${name}\[-_\](\[0-9.\]+)${extract.suffix}
Note: See TracBrowser for help on using the repository browser.