source: trunk/dports/www/drupal6/Portfile @ 57560

Last change on this file since 57560 was 57560, checked in by and.damore@…, 11 years ago

drupal5 and drupal6 update, added conflicts between postgresql and mysql variants

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 2.9 KB
Line 
1# $Id: Portfile 57560 2009-09-13 07:37:14Z and.damore@macports.org $
2
3PortSystem          1.0
4
5name                drupal6
6version             6.13
7categories          www php
8platforms           darwin
9
10maintainers         acquia.com:chuck
11description         Drupal Open Source enterprise content management platform
12long_description    Drupal is Open Source social publishing software that empowers individuals, teams, and communities  \
13                    to easily publish, manage and organize a wide variety of content on a website. Tens of thousands of \
14                    people and organizations have used Drupal to power scores of different web sites, including community \
15                    web portals, corporate web sites, social networking sites, personal web sites or blogs, and much more.
16                   
17homepage            http://drupal.org/
18distname            drupal-${version}
19master_sites        http://ftp.drupal.org/files/projects/ \
20                    http://ftp.osuosl.org/pub/drupal/files/projects/
21checksums           md5     76dcb6e311fbb98ca3322fd1413f4a04 \
22                    sha1    ac4df01933267261021cc13ea48dea5e9946529b \
23                    rmd160  5e08333266cff012c766eac8c62f1c9468d8bb89
24depends_lib         port:apache2 \
25                    port:php5 \
26                    port:mysql5
27
28variant apache1 description "use apache 1.x instead of apache 2.x" {
29  depends_lib-append      port:apache
30  depends_lib-delete      port:apache2
31}
32
33variant php4 description "use php4 instead of php5" {
34  depends_lib-append      port:php4
35  depends_lib-delete      port:php5
36}
37
38variant mysql4 description "use mysql4 instead of mysql5" {
39  depends_lib-append      port:mysql4
40  depends_lib-delete      port:mysql5
41}
42
43variant postgresql conflicts mysql4 requires postgresql84 description "use postgresql as the drupal database" {
44}
45
46variant postgresql80 conflicts mysql4 description "use postgres80 as the drupal database" {
47  depends_lib-append      port:postgresql80
48  depends_lib-delete      port:mysql5
49}
50
51variant postgresql81 conflicts mysql4 description "use postgressql81 as the drupal database" {
52  depends_lib-append      port:postgresql81
53  depends_lib-delete      port:mysql5
54}
55
56variant postgresql82 conflicts mysql4 description "use postgresql82 as the drupal database" {
57  depends_lib-append      port:postgresql82
58  depends_lib-delete      port:mysql5
59}
60
61variant postgresql83 conflicts mysql4 description "use postgresql83 as the drupal database" {
62  depends_lib-append      port:postgresql83
63  depends_lib-delete      port:mysql5
64}
65
66variant postgresql84 conflicts mysql4 description "use postgresql84 as the drupal database" {
67  depends_lib-append      port:postgresql84
68  depends_lib-delete      port:mysql5
69}
70
71use_configure       no
72build               {}
73
74set docroot ${destroot}/${prefix}/www/data
75
76destroot {
77  xinstall -d -m 0755 ${docroot}/drupal6
78  eval file copy [glob ${worksrcpath}/*] ${docroot}/drupal6
79  eval file copy ${worksrcpath}/.htaccess ${docroot}/drupal6
80}
Note: See TracBrowser for help on using the repository browser.