source: trunk/dports/www/elinks-devel/Portfile @ 139229

Last change on this file since 139229 was 139229, checked in by jeremyhu@…, 4 years ago

misc: Change port:openssl dependency to path:lib/libssl.dylib:openssl

This should allow usage of libressl as a replacement for openssl in relevant
ports. Not all ports have been tested, but libressl aims for API
compatibility with OpenSSL, so it is expected to work.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Id
File size: 5.8 KB
Line 
1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
2# $Id: Portfile 139229 2015-08-08 03:10:35Z jeremyhu@macports.org $
3
4PortSystem          1.0
5
6name                elinks-devel
7conflicts           elinks
8version             0.12pre6
9revision            1
10categories          www
11maintainers         nomaintainer
12platforms           darwin
13
14description         Full-Featured Text WWW Browser
15long_description    ELinks is an advanced and well-established \
16                    feature-rich text mode web (HTTP/FTP/..) browser.
17license             GPL-2
18homepage            http://elinks.or.cz/
19
20depends_build       port:pkgconfig
21depends_lib         port:bzip2 \
22                    port:expat \
23                    port:gettext \
24                    port:libiconv \
25                    port:libidn \
26                    path:lib/libssl.dylib:openssl \
27                    port:spidermonkey \
28                    port:tre \
29                    port:zlib
30
31distname            elinks-${version}
32master_sites        ${homepage}download/
33checksums           rmd160  68703f9fa8862c243a8083833d8447d4e09280ff \
34                    sha256  c0b3a7871f4aea954b0a66d5bbc6ce6de55ad17aa25aba3987f775707067c800
35
36patchfiles          patch-Makefile.lib.diff \
37                    patch-configure.diff
38
39variant universal {}
40
41post-patch {
42    reinplace "s|@ARCHS@|[get_canonical_archflags]|g" ${worksrcpath}/Makefile.lib
43}
44
45configure.args      --disable-256-colors \
46                    --disable-88-colors \
47                    --disable-debug \
48                    --disable-fsp \
49                    --disable-smb \
50                    --disable-true-color \
51                    --enable-bittorrent \
52                    --enable-cgi \
53                    --enable-exmode \
54                    --enable-finger \
55                    --enable-gopher \
56                    --enable-html-highlight \
57                    --enable-nntp \
58                    --with-idn \
59                    --with-libiconv \
60                    --with-openssl \
61                    --with-spidermonkey=${prefix} \
62                    --with-tre \
63                    --without-gc \
64                    --without-gnutls \
65                    --without-gpm \
66                    --without-gssapi \
67                    --without-guile \
68                    --without-lua \
69                    --without-lzma \
70                    --without-perl \
71                    --without-python \
72                    --without-ruby \
73                    --without-see \
74                    --without-x \
75                    --without-xterm
76
77if {${os.major} < 11 || ${os.platform} ne "darwin"} {
78    configure.args-delete   --without-gc
79    configure.args-append   --with-gc
80    depends_lib-append      path:include/gc.h:boehmgc
81}
82
83use_parallel_build  no
84
85# elinks-0.12pre5/src/ecmascript/Makefile needs GNU Make 3.81 or later
86# due to the "else" followed by a conditional.
87platform darwin 8 {
88    depends_build-append    port:gmake
89    build.cmd               ${prefix}/bin/gmake
90}
91
92compiler.blacklist          llvm-gcc-4.2
93
94variant colors description {Enable support for 88/256 colors and True color} {
95    configure.args-delete   --disable-256-colors \
96                            --disable-88-colors \
97                            --disable-true-color
98    configure.args-append   --enable-256-colors \
99                            --enable-88-colors \
100                            --enable-true-color
101}
102
103variant debug description {Enable debug mode} {
104    configure.args-delete   --disable-debug
105    configure.args-append   --enable-debug
106}
107
108variant fsp description {Enable support for FSP (File Service Protocol)} {
109    depends_build-append    port:fsplib
110
111    configure.args-delete   --disable-fsp
112    configure.args-append   --enable-fsp
113}
114
115variant gnutls description {Use GnuTLS instead of OpenSSL} {
116    depends_lib-delete      path:lib/libssl.dylib:openssl
117    depends_lib-append      port:gnutls \
118                            port:libtasn1
119
120    configure.args-delete   --without-gnutls \
121                            --with-openssl
122    configure.args-append   --with-gnutls \
123                            --without-openssl
124}
125
126variant guile description {Enable support for Guile scripting} {
127    depends_lib-append      port:guile
128
129    configure.args-delete   --without-guile
130    configure.args-append   --with-guile
131}
132
133variant lua description {Enable support for Lua scripting} {
134    depends_lib-append      path:bin/lua:lua
135
136    configure.args-delete   --without-lua
137    configure.args-append   --with-lua=${prefix}
138}
139
140variant perl description {Enable support for Perl scripting} {
141    depends_lib-append      path:bin/perl:perl5
142
143    patchfiles-append       patch-src-scripting-perl-hooks.h.diff
144
145    configure.args-delete   --without-perl
146    configure.args-append   --with-perl
147}
148
149variant python description {Enable support for Python scripting} {
150    depends_lib-append      port:python27
151
152    configure.args-delete   --without-python
153    configure.args-append   --with-python
154    configure.python        ${prefix}/bin/python2.7
155}
156
157variant ruby description {Enable support for Ruby scripting} {
158    depends_lib-append      port:ruby
159
160    configure.args-delete   --without-ruby
161    configure.args-append   --with-ruby
162}
163
164variant samba description {Enable support for Samba} {
165    depends_lib-append          port:samba3
166
167    configure.args-delete       --disable-smb
168    configure.args-append       --enable-smb
169    configure.ldflags-append    "-L${prefix}/lib/samba3"
170}
171
172variant see description {Use SEE instead of SpiderMonkey} {
173    depends_lib-delete      port:spidermonkey
174    depends_lib-append      port:see
175
176    configure.args-append   --enable-see
177    configure.args-delete   --with-spidermonkey=${prefix}
178}
179
180default_variants    +colors
181
182livecheck.regex     {unstable version is (.*),}
183livecheck.type      regex
184livecheck.url       ${homepage}
Note: See TracBrowser for help on using the repository browser.