source: trunk/dports/www/webkit-gtk/files/ruby-1.8.patch @ 101964

Last change on this file since 101964 was 101964, checked in by ryandesign@…, 7 years ago

webkit-gtk: fix build failure with ruby versions < 1.8.7 (i.e. Leopard and Tiger; #37740)

File size: 500 bytes
  • Source/JavaScriptCore/offlineasm/offsets.rb

    old new  
    109109    File.open(file, "r") {
    110110        | inp |
    111111        loop {
    112             byte = inp.getbyte
     112            if RUBY_VERSION >= '1.8.7'
     113              byte = inp.getbyte
     114            else
     115              byte = inp.getc
     116            end
    113117            break unless byte
    114118            fileBytes << byte
    115119        }
Note: See TracBrowser for help on using the repository browser.