Changeset 100002


Ignore:
Timestamp:
Nov 23, 2012, 11:15:45 PM (7 years ago)
Author:
ryandesign@…
Message:

php-1.1.tcl: add explicit php.latest_stable_branch set to 5.4; adjust php.default_branch to consider it

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/php-1.1.tcl

    r99319 r100002  
    127127
    128128
    129 # php.default_branch: the branch of PHP which should be installed if the user
    130 # installs the stub port. The default is the largest value in php.branches and
    131 # most ports should not need to change this.
     129# php.latest_stable_branch: the latest stable branch of PHP in the php port.
     130# Ports should not change this. It should be changed here in this portgroup
     131# when the php port is updated.
     132
     133options php.latest_stable_branch
     134default php.latest_stable_branch 5.4
     135
     136
     137# php.default_branch: the branch of PHP for which the port should be installed
     138# (i.e. the subport on which a dependency will be declared) if the user
     139# installs the stub port. The default is the latest stable branch, if the port
     140# supports it, or otherwise the latest listed in ${php.branches}. Ports should
     141# not need to change this.
    132142
    133143options php.default_branch
    134 default php.default_branch      {[lindex ${php.branches} end]}
     144default php.default_branch      {[expr {[lsearch -exact ${php.branches} ${php.latest_stable_branch}] != -1 ? ${php.latest_stable_branch} : [lindex ${php.branches} end]}]}
    135145option_proc php.default_branch  php._set_default_branch
    136146
Note: See TracChangeset for help on using the changeset viewer.