Ignore:
Timestamp:
Nov 28, 2012, 3:25:19 AM (7 years ago)
Author:
ryandesign@…
Message:

mongodb: update to 2.2.2; blacklist clang by clang version not by xcode version (#37123)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/databases/mongodb/Portfile

    r99306 r100099  
    33
    44PortSystem          1.0
     5PortGroup           compiler_blacklist_versions 1.0
    56
    67name                mongodb
    78epoch               1
    8 version             2.2.1
     9version             2.2.2
    910license             AGPL-3
    1011categories          databases
     
    2021distname            ${name}-src-r${version}
    2122
    22 checksums           rmd160  55f23013edd3796cc0d5eedfaa29656eb3bd15ce \
    23                     sha256  6ddc92c859c8d018bbdf5191c15e621dfe1505f71ddd039c26b20070f634a567
     23checksums           rmd160  189519fa17dd2c4119ae15cf6c79cd6d61cb3c26 \
     24                    sha256  e646abd0a9839dec11fa4f35089aad8e9aeef628bce7832ab40a3138c7462127
    2425
    2526depends_build       port:scons
     
    5051variant universal {}
    5152
    52 compiler.blacklist gcc-4.0
    53 if {[vercmp ${xcodeversion} 4.3] < 0} {
    54     compiler.blacklist-append clang
    55 }
     53compiler.blacklist  gcc-4.0 {clang < 318.0.45}
    5654
    5755build.env           TERM=xterm \
Note: See TracChangeset for help on using the changeset viewer.