Ignore:
Timestamp:
Dec 1, 2012, 6:28:35 AM (7 years ago)
Author:
jmr@…
Message:

textmate2: fail on 10.8 as a temporary workaround to avoid hanging the buildbot (real solution still needed), and clear deps on unsupported platforms

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/editors/textmate2/Portfile

    r100162 r100163  
    2626license                 GPL-3+
    2727
    28 pre-fetch {
    29     if {${os.platform} == "darwin" && ${os.major} < 11} {
    30         ui_error "${name} only works with Mac OS X 10.7 Lion or later."
    31         return -code error "incompatible Mac OS X version"
    32     }
    33 }
    3428fetch.type              git
    3529post-fetch {
     
    6660                        port:zlib
    6761
     62if {${os.platform} != "darwin" || ${os.major} != 11} {
     63    depends_fetch
     64    depends_build
     65    depends_lib
     66    pre-fetch {
     67        ui_error "${name} only works with Mac OS X 10.7 Lion or later."
     68        return -code error "incompatible Mac OS X version"
     69    }
     70}
     71
    6872configure.env-append    builddir=${worksrcpath}/build \
    6973                        tag=-macports
Note: See TracChangeset for help on using the changeset viewer.