Ignore:
Timestamp:
Feb 4, 2013, 1:34:38 AM (7 years ago)
Author:
cal@…
Message:

libcomerr: add deactivate hack targeting kerberos5 < 1.11, because some files were previously installed by it.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/sysutils/e2fsprogs/Portfile

    r102458 r102464  
    6767        system "install_name_tool -id ${prefix}/lib/libcom_err.1.1.dylib ${destroot}${prefix}/lib/libcom_err.1.1.dylib"
    6868    }
     69
     70    pre-activate {
     71        if {![catch {set installed [lindex [registry_active kerberos5] 0]}]} {
     72            set version [lindex $installed 1]
     73            if {[vercmp $version 1.11] < 0} {
     74                # kerberos5 used to install some files now provided by libcomerr in versions < 1.11
     75                registry_deactivate_composite kerberos5 "" [list ports_nodepcheck 1]
     76            }
     77        }
     78    }
    6979}
    7080
Note: See TracChangeset for help on using the changeset viewer.