Ignore:
Timestamp:
Feb 4, 2013, 8:39:00 PM (6 years ago)
Author:
cal@…
Message:

active_variants 1.1: enforce require_active_variants constraints before archivefetch

Previously, the constraints were only checked in pre-configure, which was,
however, never run when installing from a binary package.
Closes #37936.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/active_variants-1.1.tcl

    r100618 r102552  
    189189        _check_require_active_variants
    190190}
     191
     192# register pre-archivefetch handler that checks for all requested variants
     193# this is required when downloading binary archives for a package, because
     194# pre-configure is never run for those
     195pre-archivefetch {
     196        _check_require_active_variants
     197}
Note: See TracChangeset for help on using the changeset viewer.