Changeset 102664


Ignore:
Timestamp:
Feb 6, 2013, 2:35:01 PM (4 years ago)
Author:
michaelld@…
Message:

gnuradio:

  • update devel and next to latest; and
  • add runtime dependency for QtGui variant on py*-pyqwt.
File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/science/gnuradio/Portfile

    r102009 r102664  
    44PortSystem          1.0
    55PortGroup           cmake 1.0
     6PortGroup           active-variants 1.1
    67
    78name                gnuradio
     
    2324
    2425    version                     3.6.3
     26    revision        1
    2527
    2628    conflicts       gnuradio-next gnuradio-devel
     
    4547        This port is kept up with the GNU Radio GIT Master branch, which is typically updated every few days to week.  This version of GNU Radio generally contains fixes to, and its API is compatible with, the current GNU Radio release, and will be incorporated in an upcoming release.  This port may or not compile or function correctly, as it represents a work in progress.  If it does not work, check back in a few days.  Or try deactivating the currently active gnuradio port, cleaning any current builds, and trying again.
    4648
    47     version             3.6.4_20130120
     49    version             3.6.4_20130205
    4850
    4951    conflicts           gnuradio gnuradio-next
     
    5153    fetch.type          git
    5254    git.url             git://gnuradio.org/gnuradio.git
    53     git.branch          4435082f6167f0b5b519deaa1609572d596757dc
     55    git.branch          3acdc997b2c03f6897f5c598842ba91d93586f3e
    5456
    5557    livecheck.type      none
     
    6264        This port is kept up with the GNU Radio GIT Next branch, which is typically updated every few days to week.  This version of GNU Radio represents the next major release of GNU Radio, and hence its API is likely to be different than that provided by either gnuradio or gnuradio-devel.  This port may or not compile or function correctly, as it represents a work in progress.  If it does not work, check back in a few days.  Or try deactivating the currently active gnuradio port, cleaning any current builds, and trying again.
    6365
    64     version             3.7.0_20130123
     66    version             3.7.0_20130205
    6567
    6668    conflicts           gnuradio gnuradio-devel
     
    6870    fetch.type          git
    6971    git.url             git://gnuradio.org/gnuradio.git
    70     git.branch          54c0f407b7045b821e03bbe95875590c3bea666b
     72    git.branch          be45281798f35b7e2ec2380503b97590d6b754b4
    7173
    7274    variant ctrlport description {Enable control port enhancements (EXPERIMENTAL)} {}
     
    193195                depends_lib-append \
    194196                    port:py${s}-pyqt4
     197                depends_run-append \
     198                    port:py${s}-pyqwt
    195199
    196200            }
Note: See TracChangeset for help on using the changeset viewer.