Ignore:
Timestamp:
Feb 11, 2013, 2:46:02 AM (6 years ago)
Author:
jeremyhu@…
Message:

gcc*: Use compiler_blacklist_versions

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/lang/gcc46/Portfile

    r102174 r102942  
    33PortSystem 1.0
    44PortGroup select 1.0
     5PortGroup compiler_blacklist_versions 1.0
    56
    67name                gcc46
     
    120121
    121122# http://trac.macports.org/ticket/29104
    122 if {[vercmp $xcodeversion 4.2] < 0} {
    123     compiler.blacklist-append llvm-gcc-4.2
    124 }
    125 
    126 # TODO: base should do this: http://trac.macports.org/ticket/32542
    127 if {[info exists portconfigure::compiler_name_map(${configure.compiler})]} {
    128     depends_build-append port:$portconfigure::compiler_name_map(${configure.compiler})
    129 
    130     # base 2.1.x ignores the argument and just use ${configure.compiler}
    131     if {[portconfigure::arch_flag_supported ${configure.compiler}]} {
    132         depends_skip_archcheck-append $portconfigure::compiler_name_map(${configure.compiler})
    133     }
    134 
    135     if {[string match macports-gcc* ${configure.compiler}]} {
    136         depends_lib-append port:$portconfigure::compiler_name_map(${configure.compiler})
    137     }
    138 }
     123compiler.blacklist-append {llvm-gcc-4.2 < 2336.1}
    139124
    140125build.target        bootstrap
Note: See TracChangeset for help on using the changeset viewer.