Ignore:
Timestamp:
Mar 15, 2013, 3:48:38 PM (6 years ago)
Author:
kimuraw@…
Message:

port1.0/group/ruby-1.0.tcl: use "--vendor" of mkmf for extconf.rb, not vendor-specific.rb

mkmf/extconf ofruby-1.8.7 or later provides "--vendor" option to install libraries
under vendordir/vendorlibdir/vendorarchdir.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/ruby-1.0.tcl

    r104006 r104090  
    343343        }
    344344        extconf.rb {
    345             configure.cmd       ${ruby.bin} -rvendor-specific extconf.rb
     345            configure.cmd       ${ruby.bin} extconf.rb
    346346            configure.pre_args
    347             configure.args      --prefix=${prefix}
    348 
    349             build.args          RUBY="${ruby.bin} -rvendor-specific"
    350 
    351             destroot.args       RUBY="${ruby.bin} -rvendor-specific"
     347            configure.args      --prefix=${prefix} --vendor
     348
     349            build.args          RUBY="${ruby.bin}"
     350
     351            destroot.args       RUBY="${ruby.bin}"
    352352            post-destroot {
    353353                foreach file [readdir ${destroot}${prefix}/bin] {
Note: See TracChangeset for help on using the changeset viewer.