Changeset 107821


Ignore:
Timestamp:
Jul 6, 2013, 8:26:24 AM (5 years ago)
Author:
ryandesign@…
Message:

mongodb, oracle-instantclient, curl, VillainousStyle, pure-gen, MyPaint, keybinder, fontconfig, graphviz-oldgui, openni, ttf2eot: use eq and ne for string comparisons

Location:
trunk/dports
Files:
11 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/databases/mongodb/Portfile

    r107717 r107821  
    8888startupitem.executable  sudo -u ${mongouser} ${prefix}/bin/mongod --dbpath ${dbdir} --logpath ${logdir}/mongodb.log --logappend
    8989
    90 if {${os.platform} == "darwin" && ${os.major} < 10} {
     90if {${os.platform} eq "darwin" && ${os.major} < 10} {
    9191    depends_build
    9292    depends_lib
  • trunk/dports/databases/oracle-instantclient/Portfile

    r104771 r107821  
    1717    Oracle Instant Client allows you to run your applications without installing the standard Oracle client or having an ORACLE_HOME.
    1818
    19 if {"powerpc" == ${os.arch}} {
     19if {${os.arch} eq "powerpc"} {
    2020    epoch               1
    2121    version             10.1.0.3
     
    7171    set my_library_prefix(x86_64)   /ade/b/2649109290
    7272   
    73     if {${os.platform} == "darwin" && ${os.major} < 9} {
     73    if {${os.platform} eq "darwin" && ${os.major} < 9} {
    7474        pre-fetch {
    7575            ui_error "${name} on Intel requires OS X 10.5 or greater."
     
    102102    foreach distfile ${distfiles} {
    103103        set distfile [strsed ${distfile} {/:.*$//}]
    104         if {![catch {strsed [exec [findBinary file $portutil::autoconf::file_path] ${distpath}/${distfile} --brief --mime] {s/;.*$//}} mimetype] && "text/html" == ${mimetype}} {
     104        if {![catch {strsed [exec [findBinary file $portutil::autoconf::file_path] ${distpath}/${distfile} --brief --mime] {s/;.*$//}} mimetype] && ${mimetype} eq "text/html"} {
    105105            lappend bad_distfiles ${distfile}
    106106            file delete ${distpath}/${distfile}
  • trunk/dports/devel/VillainousStyle/Portfile

    r95899 r107821  
    3333}
    3434
    35 if {${name} == ${subport}} {
     35if {${name} eq ${subport}} {
    3636    supported_archs     noarch
    3737    distfiles
  • trunk/dports/devel/pure-gen/Portfile

    r104220 r107821  
    5252}
    5353if {![variant_isset gcc43] && ![variant_isset gcc44] && ![variant_isset gcc45] && ![variant_isset gcc46]} {
    54     if {${os.platform} == "darwin" && ${os.major} < 9} {
     54    if {${os.platform} eq "darwin" && ${os.major} < 9} {
    5555        # gcc44 doesn't build for me on Tiger
    5656        default_variants +gcc43
  • trunk/dports/gnome/keybinder/Portfile

    r107707 r107821  
    3434                    --disable-lua
    3535
    36 if {${name} == ${subport}} {
     36if {${name} eq ${subport}} {
    3737    configure.args-append       --disable-python
    3838   
  • trunk/dports/graphics/MyPaint/Portfile

    r101337 r107821  
    7474    # directories get created, which must now be combined; see https://gna.org/bugs/?20399
    7575    fs-traverse d ${worksrcpath} {
    76         if {[file tail ${d}] == "pre-destroot"} {
     76        if {[file tail ${d}] eq "pre-destroot"} {
    7777            ui_debug "merging ${d} with destroot"
    7878            system -W ${destroot} "tar -C ${d} -c -f - .${prefix} | tar -x -p -v -f -"
  • trunk/dports/graphics/fontconfig/Portfile

    r106309 r107821  
    3131                            port:freetype
    3232
    33 if {${os.platform} == "darwin" && ${os.major} < 9} {
     33if {${os.platform} eq "darwin" && ${os.major} < 9} {
    3434    set add_fonts           /usr/X11R6/lib/X11/fonts
    3535} else {
     
    7373merger_arch_flag            no
    7474merger_arch_compiler        yes
    75 if { ${os.arch}=="i386" } {
     75if {${os.arch} eq "i386"} {
    7676    if { ${os.major} >= 10 } {
    7777        set merger_configure_args(ppc) --with-arch=ppc
  • trunk/dports/graphics/graphviz-oldgui/Portfile

    r83161 r107821  
    5050    # Remove the .DS_Store files that we don't really want to install.
    5151    fs-traverse item ${worksrcpath} {
    52         if {".DS_Store" == [file tail ${item}] && [file isfile ${item}]} {
     52        if {[file tail ${item}] eq ".DS_Store" && [file isfile ${item}]} {
    5353            delete ${item}
    5454        }
  • trunk/dports/graphics/openni/Portfile

    r103770 r107821  
    2828
    2929pre-fetch {
    30     if {${os.platform} == "darwin" && ${os.major} < 10} {
     30    if {${os.platform} eq "darwin" && ${os.major} < 10} {
    3131        ui_error "${name} ${version} requires OS X 10.6 or greater."
    3232        return -code error "incompatible OS X version"
  • trunk/dports/net/curl/Portfile

    r107230 r107821  
    2929                                sha256  a73b118eececff5de25111f35d1d0aafe1e71afdbb83082a8e44d847267e3e08
    3030
    31 if {${name} == ${subport}} {
     31if {${name} eq ${subport}} {
    3232    PortGroup                   muniversal 1.0
    3333
  • trunk/dports/print/ttf2eot/Portfile

    r74772 r107821  
    2525
    2626pre-fetch {
    27     if {"big" == ${os.endian}} {
     27    if {${os.endian} eq "big"} {
    2828        ui_error "${name} does not currently work on PowerPC Macs."
    2929        ui_error "See http://code.google.com/p/ttf2eot/issues/detail?id=14"
Note: See TracChangeset for help on using the changeset viewer.