Ignore:
Timestamp:
Feb 8, 2005, 11:06:45 PM (15 years ago)
Author:
jberry
Message:

Add check for ant version 1.6.2. Add explicit port dependency onto our ant if its not present.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/java/tomcat5/Portfile

    r10875 r10876  
    1 # $Id: Portfile,v 1.10 2005/04/01 04:46:15 jberry Exp $
     1# $Id: Portfile,v 1.11 2005/02/08 23:06:45 jberry Exp $
    22
    33PortSystem 1.0
     
    5454set tomcatuser          www
    5555set tomcatgroup         www
     56
     57# Tomcat in this version requires ant 1.6.2.
     58# If the current version of ant is not 1.6.2 then add an
     59# explicit dependency onto our ant port to get 1.6.2.
     60if { [string length [auto_execok ant]] } {
     61        set verOutput [exec ant -version]
     62        regexp {version (\d*(\.\d*(\.\d*)?)?)} $verOutput -> antVersion
     63        if { $antVersion != "1.6.2" } {
     64                depends_build-append bin:XXX:apache-ant
     65        }
     66}
    5667
    5768use_configure           no
Note: See TracChangeset for help on using the changeset viewer.